Long time user - current bad support

Post Reply
impactoz
Posts: 2
Joined: Fri Sep 13, 2019 2:17 am

Long time user - current bad support

Post by impactoz » Fri Sep 13, 2019 2:45 am

I have been using Blue Iris for a number of years... Since v3 and have always found it a good product, recommending it to many others...

While on v4, I noticed a few issues with people upgrading to v5, so I decided to wait awhile for any issues to be sorted. Pulled the plug this week and went the upgrade path - and its the worse thing I have done.

Bought a renewal of support maintenance, received a key.

Thought I had my v4 key... did the backups etc. Installed BI5

Setup asks for my key - I tried entering the support maintenance key - it complained wrong key... I entered my v4 key and it wont accept it... I now believe that was my original key from v3.

So none my keys work - email support.

I cant click the button in the software to copy diagnostics to give to blue iris, as the software does not run - I cant run v4 anymore. v5 comes up asking for a key, without a key it does not continue. If I click on Demo - it does nothing - as right from the start it has said demo days - 0.

Its been 2 days since I have emailed support, and no answers - I find the message received aggressive - if you reply to this email, it will be placed at the bottom of the queue and it will take longer - is this the way to treat a paying customer...

That's 2 days without any video recording... and unknown amount of time waiting for some support on information about my key... I just need things reset and provided to me so I can move on.

I understand the need to protect software, registrations, ensuring that they are valid users etc - but there is something screwed in the current convulted system - never have issues with other companies. Why make it so hard !

So NOT HAPPY at present.

Post Reply