Windows 10 100% Disk Usage

Post Reply
kbailey
Posts: 2
Joined: Mon Oct 05, 2020 1:27 pm

Windows 10 100% Disk Usage

Post by kbailey » Mon Oct 05, 2020 1:56 pm

I Need some help with this.
I have a system running on Windows 10, and the Disk Usage (as seen on the disk page of Resource Monitor, or Performance page of Task Manager) is frequently 100%. But not always. Using the Resource Monitor, it shows a 'System' process reading a single recorded file (not an active file, one from a previous day), the specific file changes; It is almost as though it was scanning each file in turn. At the times when this process is NOT active (which seem random), the disk usage is fairly low, but when it is running, viewing ANY of the recorded video stored on that drive is nearly impossible (stop, start, jumpy, etc...). This is becoming a serious problem. It has been a problem since the system was brought online, and i have spent time working on it, but it is clearly beyond my skills to solve.
I have tried everything I know. I have disabled windows defender as best i can, and added exceptions for Blue Iris, .BVR files, and specific locations. I have turned off the automatic optimization (Defrag) for that drive. All have had no effect. I have also tried almost every suggestion found via Google; I have not tried disabling MSI mode, as that issue appears to only affect SSDs, and the drive in question is not an SSD.
There are some details on my configuration below. I am hoping someone else has encountered this issue, and can help me fix it.


Intel i7-8700. 32 GB RAM. 480GB M.2 SSD for the Operating System. Video is recorded to a Raid 0 Array made of 3x 4TB drives. Videos are later moved to a second Raid 0 Array made of 3x 4TB drives.
High usage occurs only on the 1st Array (where files are initially stored), the SSD and 2nd array both have very low usage.

Thanks in Advance
-K
User avatar
TimG
Posts: 845
Joined: Tue Jun 18, 2019 10:45 am
Location: Nottinghamshire, UK.

Re: Windows 10 100% Disk Usage

Post by TimG » Tue Oct 06, 2020 2:29 pm

Hi K,

It sounds like a file system, Raid or anti-virus function rather than a BI5 issue. Are you able to rule those out ?

1. Does it still scan the files even if BI5 is OFF ?
2. Are you saying "New" is on one 3x 4TB array, and "Storage" is on a second 3x 4TB array ?
3. Do you have a spare single drive that you could hook up as a temporary "New" folder ? (Or is the Raid array due to a very large number of cameras ?).
4. Are you certain that you don't have malware on this pc ? It may be worth running a McAfee Stinger (free) to see if it finds anything.

Tim
Blue Iris v5.3.9.10 x64 | Win10 x64 version 20H2 | Dahua IPC-HDW5231R-ZE, Foscam R2, Ertech 4MP, Neos2, 2 analogue cameras on Euresys Picolo Pro 2 | Intel i5-3330 CPU, 16GB Ram, Multiple SSD and HD | TVMosaic.
kbailey
Posts: 2
Joined: Mon Oct 05, 2020 1:27 pm

Re: Windows 10 100% Disk Usage

Post by kbailey » Thu Oct 08, 2020 12:43 pm

Replying to TimG
Thanks for your response.
I agree that is seems like the problem is outside of Blue Iris, which is why I started looking on Windows 10 forums for high disk usage, but none of the relevant resolutions I found there made a difference. My hope was that someone here had seen this problem, and could help.

To answer your questions:
1. Does it still scan the files even if BI5 is OFF ?
I think so, but I can't turn Blue Iris off for any useful duration, except during facility maintenance intervals: the next will be in about 2 weeks. I will try that, at that time.
2. Are you saying "New" is on one 3x 4TB array, and "Storage" is on a second 3x 4TB array ?
Yes: "New" is on one 3x 4TB array, and "Storage" is on a second 3x 4TB array. Both are RAID 0.
3. Do you have a spare single drive that you could hook up as a temporary "New" folder ? (Or is the Raid array due to a very large number of cameras ?).
I can try hooking up a single drive as a "New" folder, but the access rate concerns me: the RAID 0 array is due to the number of cameras and resolutions.
4. Are you certain that you don't have malware on this pc ? It may be worth running a McAfee Stinger (free) to see if it finds anything.
I can't be 100% certain it has no malware, but it hasn't been connected to the internet since the initial updates when it was built. It has been scanned using Windows Security since that time, and always turned up clean. I may try the software you suggested, at the next maintenance interval. As to why Windows Security only at this point: a past experience with McAfee anti-virus destroying other software (PLC programing software) has left me wary. As this computer does not have any PLC Programing software on it I am willing to try other anti-virus software.

Thanks again for your response.
I hope to resolve this, and will post anything I find.
mikecam
Posts: 10
Joined: Wed Oct 21, 2020 9:58 am

Re: Windows 10 100% Disk Usage

Post by mikecam » Wed Oct 21, 2020 10:27 am

You say high Disk Usage, In Windows 10, Make sure your running version 2004 with all the latest windows updates, in task manager it should show you which drive is showing the high usage on the list on the left in the Performance Tab. Which drive does it show? If you then click on the bottom "Open Resource Monitor" and look at which file is using all the diskusage at the time it is happening. Unless you have 20+ cams writing to a single drive there shouldn't be any diskusage problem unless the system is hanging while writing a file. Other thing to try is download a couple of free disk speed tools and check the speed of each of your drive sets and see if you can find a problem.
If there is a drive failing in one of your raid sets it could also create a problem of high disk usage as the raid is waiting for a drive to slowly write. Do a disk check but not the windows one, seatools or WH tools on each of your drives to double-check there is no problem with on of the drives. Old drives fail and so do new ones.
Let us know how you get on.
Post Reply