"404 not found" error

Post Reply
ronsfsd
Posts: 1
Joined: Fri Jul 12, 2019 3:46 pm

"404 not found" error

Post by ronsfsd » Fri Jul 12, 2019 4:20 pm

Everything has worked great since 2016.
I decided to bite the bullet and upgrade to 5 today.
1. Saved all my settings
2. Uninstalled v4 telling it NOT to delete settings and license
3. Rebooted
4. Installed v5
5. Version 5 came up without license or settings
6. Entered license and imported settings
Everything except the Webserver, at first glance, appears to be working.

Webserver:
[With Win10 Firewall turned OFF]
When I attempt to bring up the web interface on port 81, I get “404 not found.”
When I try to bring up the web interface on port 82 (Stunnel), I get a certificate confirmation (normal) and then the same “404 not found.”
I tried moving port 81 to port 83 (adjusting Stunnel config to match). Same error on both HTTP(83) and HTTPS(82)

According to my browser's address line, it is trying to hit: http://10.10.10.9:83/login.htm?page=%2F
Thus I think the original GET/POST request is getting a redirect to the login page - which fails.

Ideas?

chuckb223
Posts: 1
Joined: Fri Jul 19, 2019 4:40 pm

Re: "404 not found" error

Post by chuckb223 » Fri Jul 19, 2019 4:41 pm

Go to the Web Server Settings page and in the ROOT: box enter:

C:\Program Files\Blue Iris 5\www

mikefr24
Posts: 2
Joined: Sun Jul 28, 2019 6:27 pm

Re: "404 not found" error

Post by mikefr24 » Sun Jul 28, 2019 6:40 pm

Hi guys.

I also had this same error after I upgraded from Blue Iris 4 to Blue Iris 5. The Web interface worked perfect before with Blue Iris 4. The ROOT setting in the Web Server Settings page was the culprit for me just like chuckb223 noted above.

My old Blue Iris 4 setting for ROOT: was "C:\Program Files\Blue Iris 4\www"

I had to change it to the new installation directory "C:\Program Files\Blue Iris 5\www" and it worked perfect.

I am not sure if this is a bug when upgrading or not.

Post Reply