IMPORT Settings: Unable to delete registry key to complete import

Post Reply
cdikland
Posts: 2
Joined: Sun Oct 06, 2019 2:07 pm

IMPORT Settings: Unable to delete registry key to complete import

Post by cdikland » Sun Oct 06, 2019 2:15 pm

I just completed a Windows 10 Reset and after re-installing the latest BI I tried to import my bi setting which I had saved just prior to the Win Reset. Now, when I try to import this same file, bi terminates without any message and after a restart I get the error shown above. I have tried re-installing, deleting the blue iris import keys from the registry but nothing appear to work.
I know that the exported settings is fine because, before the reset of Win 10 I tested importing it. No problem.

Seems I had this problem when I upgraded from 4 to 5. Anyone have a solution for this problem?

User avatar
TimG
Posts: 568
Joined: Tue Jun 18, 2019 10:45 am
Location: Nottinghamshire, UK.

Re: IMPORT Settings: Unable to delete registry key to complete import

Post by TimG » Thu Oct 10, 2019 2:12 pm

Hi, send a message to support. They sometimes read stuff here, but not always.
Blue Iris v5.2.9.5 | Win10 Pro x64 version 2004 | Dahua IPC-HDW5231R-ZE, Foscam R2, Ertech 4MP, 2 analogue cameras on Euresys Picolo Pro 2 | FX-8350 AMD Piledriver CPU, 32GB Ram, Multiple SSD and HD| Homeseer HS3(4) Pro | TVMosaic | Emby | DVBViewer |

User avatar
reddawg
Posts: 131
Joined: Sun Jun 30, 2019 11:29 am

Re: IMPORT Settings: Unable to delete registry key to complete import

Post by reddawg » Fri Oct 11, 2019 3:14 am

This problem is caused by a permission issue on the a1 key in HKEY_LOCAL_MACHINE\SOFTWARE\Perspective Software\Blue Iris\. Open REGEDIT, navigate to HKEY_LOCAL_MACHINE\SOFTWARE\Perspective Software\Blue Iris and edit permissions on the a1 key so the Everyone group has "Full Control".
Blue Iris a1 reg key problem.png
Blue Iris a1 reg key problem.png (38.56 KiB) Viewed 2423 times
https://blueirissoftware.com/forum/view ... ?f=4&t=169

User avatar
CasaDelGato
Posts: 13
Joined: Sat Nov 09, 2019 1:18 am

Re: IMPORT Settings: Unable to delete registry key to complete import

Post by CasaDelGato » Sat Nov 09, 2019 1:40 am

This fix doesn't seem to work for me.
I have the latest Blue Iris. I can make the change (as administrator), and verify it changed. (though I did have to add the "Everyone" group)
After the system reboots - the permissions are reverted back to their old settings.

This is on Win 10 Pro, 10.0.18362 Build 18362

User avatar
CasaDelGato
Posts: 13
Joined: Sat Nov 09, 2019 1:18 am

Re: IMPORT Settings: Unable to delete registry key to complete import

Post by CasaDelGato » Sat Nov 16, 2019 8:18 pm

It appears that the Blue Iris service, when it starts, causes all the permissions on that key to be reverted to their original values.
I can Stop the service, update the permissions, Verify the permission changes, and Start the service.
Once the service is started, all the changes to the permissions are gone.

nosecuser
Posts: 3
Joined: Wed Nov 20, 2019 10:23 am

Re: IMPORT Settings: Unable to delete registry key to complete import

Post by nosecuser » Wed Nov 20, 2019 10:26 am

Running into this same issue. Also, the windows service does not seem to start correctly even though the service says its running. I cannot connect via phone app unless the UI is running.

nosecuser
Posts: 3
Joined: Wed Nov 20, 2019 10:23 am

Re: IMPORT Settings: Unable to delete registry key to complete import

Post by nosecuser » Wed Nov 20, 2019 10:36 am

CasaDelGato wrote:
Sat Nov 16, 2019 8:18 pm
It appears that the Blue Iris service, when it starts, causes all the permissions on that key to be reverted to their original values.
I can Stop the service, update the permissions, Verify the permission changes, and Start the service.
Once the service is started, all the changes to the permissions are gone.
Try on A1 entry for both the Blue Iris and Blu Iris Import keys

User avatar
CasaDelGato
Posts: 13
Joined: Sat Nov 09, 2019 1:18 am

Re: IMPORT Settings: Unable to delete registry key to complete import

Post by CasaDelGato » Wed Nov 20, 2019 7:13 pm

Made the change to both keys, and launched UI - still had the error.
BUT the UI then downloaded and installed the latest update.
I then rebooted the system, and it appears to be working now.

Just re-checked the permissions - and my changes are reverted again. AND the "Blue Iris Import" key is gone.

Post Reply