Camera Stream Gotchas - Live View

Post Reply
varghesesa
Posts: 61
Joined: Thu Jul 11, 2019 9:52 pm

Camera Stream Gotchas - Live View

Post by varghesesa » Thu Sep 02, 2021 1:44 am

Introduction

Not being able to connect cameras and streaming correctly can be a real frustration. This article does a deep dive on how to resolve this one issue.
Fortunately live view has a very simple video pipeline: Camera settings -> Decode -> Console view

Troubleshooting

Windows

Anti-virus and Firewall settings can adversely affect network connectivity.
Good to run through all the checks in the Windows tuning article.
Pay attention to the Anti-virus and Firewall settings.
viewtopic.php?f=20&t=2080#Antivirus

Camera settings
First what are the camera stats? Camera settings -> General tab
Are the stats lousy, e.g. 1 fps? If so, we need to figure out whether we have a BI issue, a network issue or a camera issue?

This is a good time to check your camera settings. The Camera settings article shares ideal camera settings.

VLC / Third party software
This is the critical step. It rules out network and camera hardware issues. Does the camera work with other 3rd party software. VLC is the ideal test because you can install it on the same BI server.
By doing so, if VLC works, then you know for sure the camera is not the issue nor is the network.
The VLC article has details on how to install/run VLC if you are not familiar with VLC.


Camera connector (IP Config Dialog)
The IP Config Dialog determines how the cameras connect to BI.
Revisit your settings.
  • Make/Model = ONVIF/Generic. Works?
  • Make/Model = <Camera vendor>/<Model>. Works? (did you try all the models to see if any works?)
  • Make/Model = Generic / VLC. Works?
    If the camera works using VLC, try the VLC option in BI. This tells BI to use the VLC stream parser. Otherwise, BI uses its own stream parser.
    live view vlc.png
    live view vlc.png (7.69 KiB) Viewed 2945 times
The Camera Connector article outlines ALL the issues/fixes associated with connecting cameras from past tickets.

Decode

Turn Hardware acceleration on/off. Works?
Camera settings -> Video tab -> Hardware decode = No.

The Video tab article details ALL the server settings that can affect the video stream.

Camera stats

After above tweaks, check the camera stats. Are the cameras and the network delivering consistent streams?
See Video tab for details.

Next steps

If still unsuccessful, put the camera on the WAN for Remote testing.
Post Reply