Raspberry Pi IP Camera

Post Reply
wjburl
Posts: 1
Joined: Fri Jun 19, 2020 3:15 pm

Raspberry Pi IP Camera

Post by wjburl » Thu Jun 25, 2020 8:08 pm

I would like to use my Raspberry Pi with an RPi camera to feed into Blue Iris SW. I can use raspivid to output a stream using VLC and I can view the stream on a PC using VLC. I use the Open Network Stream and enter 192.168.2.111:8554/stream. That way I can see the stream on the PC. Is there a way to set up the RPi to add it as a camera to Blue Iris SW?
MikeBwca
Posts: 684
Joined: Thu Jun 20, 2019 5:39 am

Re: Raspberry Pi IP Camera

Post by MikeBwca » Sun Jun 28, 2020 4:57 am

Wow. So many things between the camera and BlueIris.

I tried streaming VLC, and it works. But I choose not to do it... lots of extra cpu/gpu.
toddmc451
Posts: 1
Joined: Sat Jul 18, 2020 9:21 pm

Re: Raspberry Pi IP Camera

Post by toddmc451 » Sat Jul 18, 2020 9:24 pm

Did you ever get Blue Iris to recognize the Raspberry Pi Camera? If YES, please tell us how you configured everything! THANK YOU! :D
Malstrond
Posts: 2
Joined: Sat Apr 11, 2020 4:33 pm

Re: Raspberry Pi IP Camera

Post by Malstrond » Sat Dec 12, 2020 11:41 am

I'm using uv4l-raspicam for this. -> documentation.
uv4l presents a raw H264 stream at /stream/video.h264.
I connected Blue Iris to that with the following settings:
Camera URL: http://[IP of RPi]:8080
Make: Generic/ONVIF
Model: Raw H.264
Stream Profiles - Main: /stream/video.h264

There are a ton more configuration options listed here.
You set them in /etc/uv4l-raspicam.conf. Noteworthy options are...
To get H264 streams:
encoding = h264
Resolution:
width =
height =

This sets your framerate to dynamic, a very neat feature. At daytime the Pi cranks the FPS up as far as it can while at night it can lower the framerate down to 1, while increasing the exposure time. This provides a usable image even with no IR LEDs with just street lighting:
framerate = 0
To avoid pixel binning:
custom-sensor-config =
Also required for dynamic FPS is auto ISO:
iso = 0
Increase exposure at night, still works fine at daytime:
exposure = night
Enable AWB:
awb = auto
Enable WDR:
drc = high
To disable WebRTC if you just use the stream functionality, saves some RAM:
server-option = --enable-webrtc=no
H264 quality options:
profile =
level =

If you want CBR at 2mbit/s:
bitrate = 2000000
OR if you want VBR:
quantisation-parameter = 25
Post Reply