Problem with corrupted converted/exported files

General discussion about Blue Iris
ctfjr
Posts: 22
Joined: Mon Oct 14, 2019 5:43 pm

Problem with corrupted converted/exported files

Post by ctfjr » Tue Feb 11, 2020 9:50 pm

This has happened before. When I try to convert/export to MP4 format the exported file is corrupt. I can tell if its going to be corrupt by watching the green 'working' timeline on the conversion screen. If it goes all the way to end the exported file is fine. If it closes that screen before it reaches the end then the file is no good. The last time this happened I thought it was because I had changed the 'quality %' on the encoder page to 75. When I put it back to 50 everything seemed ok. Now changing that setting doesn't help. Some files are ok, some not so much (same camera). The file that I exported as MP4 and was corrupt I was able to export as AVI just fine,
Any suggestions?

MikeBwca
Posts: 383
Joined: Thu Jun 20, 2019 5:39 am

Re: Problem with corrupted converted/exported files

Post by MikeBwca » Wed Feb 12, 2020 10:44 pm

What version are you on, and when did it start happening?

Please provide a screen capture of the Export window, and, the encoder profile.

zStrange. I just exported a few cameras, and I get no video. Just a black screen. It was workinga week ago. I've updated to the latest version 5.0.9.5.


Update:
I figured out why all my exports were black. Only happened on Encoder profiles 1 & 2. The 'Use Nvida hardware ecceleration' was enabled on encoder profiles 1 & 2! How it got enabled I have no idea. I unchecked that option on profiles 1 & 2, and now export works. maybe it was always enabled, and something else changed. IHNI

ctfjr
Posts: 22
Joined: Mon Oct 14, 2019 5:43 pm

Re: Problem with corrupted converted/exported files

Post by ctfjr » Thu Feb 13, 2020 1:18 am

Thank you very much for the reply. I got all tingly when you mentioned Nvidia acceleration - I had mine set always but unchecked it hoping. . . no help tho
Here is a screen shot of the convert/export window that just failed - the progress bar just stopped where you see it:
config_screen.PNG
config_screen.PNG (95.26 KiB) Viewed 812 times
export_capture screenshot1.PNG
export_capture screenshot1.PNG (93.46 KiB) Viewed 812 times
I am running release 5.0.9.2

ctfjr
Posts: 22
Joined: Mon Oct 14, 2019 5:43 pm

Re: Problem with corrupted converted/exported files

Post by ctfjr » Thu Feb 13, 2020 1:35 am

Thanks Mikebwca!

I just saw your BI version was more recent than mine. I updated to 5.0.9.5 and all is well :)

Thank you very much!

MikeBwca
Posts: 383
Joined: Thu Jun 20, 2019 5:39 am

Re: Problem with corrupted converted/exported files

Post by MikeBwca » Thu Feb 13, 2020 9:18 am

Oh! Wow! Didn't even consider it could be fixed by updated to latest version. :oops:

ctfjr
Posts: 22
Joined: Mon Oct 14, 2019 5:43 pm

Re: Problem with corrupted converted/exported files

Post by ctfjr » Thu Feb 13, 2020 11:09 pm

nope, didn't fix it :(
I converted a couple of files last night fine but today its barfing again. I am able to save the clips in AVI format most of the time but not MP4.

MikeBwca
Posts: 383
Joined: Thu Jun 20, 2019 5:39 am

Re: Problem with corrupted converted/exported files

Post by MikeBwca » Fri Feb 14, 2020 2:13 am

What fixed it for me was changing the Encoder profile from 'default' to 'main'.

ctfjr
Posts: 22
Joined: Mon Oct 14, 2019 5:43 pm

Re: Problem with corrupted converted/exported files

Post by ctfjr » Sat Feb 15, 2020 1:21 am

Tried changing to every option in the encoder profile list. Very discouraging. I even changed my viewer thinking it might be that. Just can't convert to MP4

User avatar
TimG
Posts: 452
Joined: Tue Jun 18, 2019 10:45 am
Location: Nottinghamshire, UK.

Re: Problem with corrupted converted/exported files

Post by TimG » Sat Feb 15, 2020 9:43 am

Can you convert a very small file as a test ? I'm just wondering if this is a memory issue.
Blue Iris v5.2.3.0 | Win10 Pro x64 | Dahua IPC-HDW5231R-ZE, Foscam R2, Ertech 4MP, 2 analogue cameras on Euresys Picolo Pro 2 | FX-8350 AMD Piledriver CPU, 32GB Ram, Multiple SSD and HD| Homeseer HS3(4) Pro | TVMosaic | Emby | DVBViewer |

ctfjr
Posts: 22
Joined: Mon Oct 14, 2019 5:43 pm

Re: Problem with corrupted converted/exported files

Post by ctfjr » Sat Feb 15, 2020 9:05 pm

Hello TimG

No even small files won't convert to MP4's. I am able to convert pretty large (>300mb) files to AVI tho. If its a memory issue I'd be pretty surprised. BI shows 3.89gb memory usage. The system has 64gb minus 12gb I use as a ram disk. Overall task manger shows:
task_manager.PNG
task_manager.PNG (26.3 KiB) Viewed 707 times

Post Reply