Codeproject.AI v2.5.5 not working

Post Reply
n4mwd
Posts: 8
Joined: Thu Feb 22, 2024 12:39 pm

Codeproject.AI v2.5.5 not working

Post by n4mwd »

I upgraded BI to the latest unstable version which seemed to work with everything except matters concerning AI. When I tried to do anything with AI, BI would freeze for about 30 seconds and go full screen so I couldn't do anything else.

So I figured I would upgrade CPAI to the latest which is stated to be 2.5.5. However, this AI service would not start or run at all. Trying to start it from the BI setup AI tab just freezes BI again. The AI web interface was unreachable.

So I downgraded BI to the latest stable version 5.8.6.7, restarted and CPAI still wont load. So then I uninstalled CPAI and wiped the codeproject directory and reinstalled CPAI 2.5.4. This version will now load, but it is unstable and frequently crashes and BI has to constantly restart it.

Not only that, but before I upgraded BI, CPAI was only taking about 200ms to scan an image. Now its taking upwards to 2000ms.

My CPU is the Intel i5-1235U which supports intel quicksync. I do not have any nvidia / cuda GPUs. Nevertheless, I think it was using the intel GPU before and now its not. I have seen the CPU% spike up to 60% when there is motion and the AI is in use. Before, it would never go over 12% and usually stayed around 3% with no motion.

Has anyone else seen this failure with CPAI v2.5.5?
Elprebse
Posts: 9
Joined: Tue Feb 15, 2022 7:45 am

Re: Codeproject.AI v2.5.5 not working

Post by Elprebse »

Yes, I had the same issue with CPAI v2.5.5.
Have rolled back to 2.5.4.
User avatar
Sardon
Posts: 114
Joined: Sun Nov 19, 2023 10:50 am

Re: Codeproject.AI v2.5.5 not working

Post by Sardon »

I was just about to upgrade but think I may hold off !
User avatar
TimG
Posts: 2160
Joined: Tue Jun 18, 2019 10:45 am
Location: Nottinghamshire, UK.

Re: Codeproject.AI v2.5.5 not working

Post by TimG »

There are a few posts about it on the CPAI forum. Best to wait unless you keep regular back ups.
Forum Moderator.
Problem ? Ask and we will try to assist, but please check the Help file.
n4mwd
Posts: 8
Joined: Thu Feb 22, 2024 12:39 pm

Re: Codeproject.AI v2.5.5 not working

Post by n4mwd »

TimG wrote: Wed Feb 28, 2024 4:48 pm There are a few posts about it on the CPAI forum. Best to wait unless you keep regular back ups.
Thanks, I'm glad to know I'm not the only one. However there was some change in Blue Iris that caused a spike in CPU usage. This was just an upgrade from last week's version, so it wasn't a huge jump.
Elprebse
Posts: 9
Joined: Tue Feb 15, 2022 7:45 am

Re: Codeproject.AI v2.5.5 not working

Post by Elprebse »

Seems like v2.5.5 was pulled again.
rdxny
Posts: 26
Joined: Sun Jul 16, 2023 6:25 pm

Re: Codeproject.AI v2.5.5 not working

Post by rdxny »

CPAI 2.5.6 posted, installed ok on win 10 and win 11, and seems working ok.
n4mwd
Posts: 8
Joined: Thu Feb 22, 2024 12:39 pm

Re: Codeproject.AI v2.5.5 not working

Post by n4mwd »

I downloaded 2.5.6 as well and everything seems to be working here. The frame processing times are back down to 100ms with the Intel GPU. I will probably stay on the latest stable version of BI for now.
Post Reply