How to assign Static IP addresses to my cameras.

For anything else on your mind
Post Reply
Posts: 20
Joined: Sun Feb 18, 2024 7:14 pm

How to assign Static IP addresses to my cameras.

Post by HughS »

Looking for some help.. Searched the docs, may have over looked it, but unable to find how to assign 'Static' IP's to my cameras... when trouble shooting or just playing with the settings, the IP addresses keep changing on me.. I was not able to see any DHCP controls.. I am sure it is in the docs somewhere, I am just missing it when scanning. Can someone point me in the right direction to assign Static IP's to the cameras. Thanks in advance.

Posts: 1076
Joined: Thu Jun 20, 2019 5:39 am

Re: How to assign Static IP addresses to my cameras.

Post by MikeBwca »

You could try to use the BI setting... 'MAC, HTTP, DSN reachability'. In BI camera settings 'Video' tab, click 'Configure'. Make sure the option is unchecked.

This tries to find the camera by it's MAC address rather than IP.
User avatar
Posts: 2142
Joined: Tue Jun 18, 2019 10:45 am
Location: Nottinghamshire, UK.

Re: How to assign Static IP addresses to my cameras.

Post by TimG »

There are two ways to do it, but they are not part of BI5 so will be different for every installation. Either method will require you to update the camera IP in BI5 when you have altered it.

1. Log in to router. Check which address range is handed out by the router as automatic dhcp IP addresses. Do not choose static IP addresses in that range.

Now either:

2. Set up an address reservation for a camera in the router. This usually involves seeing the cameras existing MAC and IP, and assigning a new IP address out of the dhcp range.


3. Log in to each camera and find network settings menu. Change from dhcp to manual, and set an IP address out of the dhcp range.

Belt and braces is to do both.
Forum Moderator.
Problem ? Ask and we will try to assist, but please check the Help file.
Posts: 686
Joined: Thu Jul 18, 2019 2:50 pm

Re: How to assign Static IP addresses to my cameras.

Post by HeneryH »

Yeah, two similar topics are a) statically assigned ip addresses assigned in the router which will then get assigned to the devices on boot or b) statically assigned in the camera settings.
User avatar
Posts: 412
Joined: Tue Jul 18, 2023 7:21 pm
Location: Reportedly in the Area

Re: How to assign Static IP addresses to my cameras.

Post by Pogo »

Simply applying a static address to a camera by its own settings has the potential for an address conflict if not also entered into a reserved state on the router / DHCP server address pool and bound to the camera MAC address -- or is assigned from a reserved range of the same subnet outside the DHCP server's address pool as previously posted.

A camera that is initially set up with DHCP for subsequent addition to Blue Iris using the assigned address will also continue to receive that same dynamically assigned address if the first step above is followed to bind the dynamic address to the camera MAC address in the DHCP server.

(Sorry, but 'Update Router Settings' just seemed sorta vague.) :)

The 'skip' setting is useful for cameras that are behind a wireless bridge or access point that will typically hide the MAC addresses of devices connected to it. If Blue Iris can't make an association between a camera MAC address it believes should have the IP address in its configuration, it will attempt to provide a working IP address to replace the one already in the configuration..., most times the IP address of the bridge or AP MAC when an interruption in power or network connectivity has occurred that only affected the bridge or AP location. The cameras themselves still have the original IP addresses and are live on the network but Blue Iris doesn't recognize that and attempts to 'correct' the problem by establishing a new address in the config to bring the cameras back online based upon the MAC it does find. This whole scenario can be fairly random when it occurs, but if there are cameras down on a wi-fi segment according to Blue Iris but they're still active on the network otherwise, the above is likely why.
Post Reply