CPU overload

Post Reply
rogervanhoven
Posts: 1
Joined: Sat Jun 06, 2020 8:08 am

CPU overload

Post by rogervanhoven » Sat Jun 06, 2020 8:20 am

Hello,

I have quiet a big installation (I thinK),

Intel Core i9-7920X CPU 2.90 GHZ
64 GB RAM
Geforce RTX 208
6x 8TB disk to record

I have 35 camera! and want to expand :)

My problem is i have a CPU load of 60 to 70 procent....

I already tried:
- direct to disk
- no antivirus
- limit decoding

Even when i stop recording al my cameras, profile inactive, and then close the BlueIris screen, i have a CPU load for blue iris of 20%

Any Ideaas?

I put som screenshots

Thanx
Attachments
CPUload2.jpg
CPUload2.jpg (167.34 KiB) Viewed 314 times
stats.JPG
stats.JPG (58.61 KiB) Viewed 314 times

MikeBwca
Posts: 541
Joined: Thu Jun 20, 2019 5:39 am

Re: CPU overload

Post by MikeBwca » Sun Jun 28, 2020 5:53 am

That is an impressive system.
Also, 35 4mp cameras! All at 15fps?
Looks like your using Nvidia NVDEC Hardware decode?

Did you mean a high GPU percent? It's 79%. Because the cpu is only 19%.
20% isn't bad. It's still streaming to BI.

One thing to check is the 'Limit live preview' fps in the BI settings 'Camera' tab. This does not effect recording, only the fps of each camera when the console is open. 10-15 acceptable. You can try 5 just to see how it effects cpu/gpu.
Opps! You already tried this!

If your processor has Quick Sync, try switching your camera to 'Intel'. The GPU should drop dramatically.

One tip: Set all your cameras 'Hardware accelerated decode' to 'Default'. Then, you only need to change the setting once in BI settings 'Camera' tab to to switch. And, you can always specify a cameras 'special' needs in the cameras settings, if need be.

I'm planning a new system, and will also be getting the GeForce GTX 2080. But, I'm planning on the Hybrid that has build in liquid cooling and radiator. The benchmarks on it are impressive.

Matts1984
Posts: 125
Joined: Fri Apr 10, 2020 1:12 pm

Re: CPU overload

Post by Matts1984 » Mon Jun 29, 2020 12:04 pm

You could also try configuring the substreams of your cameras. It should lower your processing quite a bit while still maintaining the same quality recordings.
Blue Iris 5.2.9.x | Windows Server 2019 VM | Intel Xeon X5650 @ 2.67GHz - 8 Cores | 12GB RAM | 6TB Local RAID | Sophos UTM WAF

Post Reply