Reolink Gotchas

Post Reply
varghesesa
Posts: 45
Joined: Thu Jul 11, 2019 9:52 pm

Reolink Gotchas

Post by varghesesa » Mon Feb 15, 2021 6:34 pm

Introduction

This post (article) from BI Support is so the BI Support team can provide information quickly to the community based on support findings and troubleshooting.

Reolink Gotcha - H.264 High profile

Reolink H.264 High profile (default setting) causes no signal. Switch to H.264 Baseline.



GPU

This is strictly anecdotal. I'm only mentioning this because it's a 5 min test. One user with an i7-7700K @4.20 GHz stated the Intel Beta selection for GPU worked well with his Reolinks. Not clear what "well" means. However, Intel Beta adversely affected his Amcrest cameras even with H.264 Baseline.


RLC-4xxx / RLC-5xx series

Most cameras connect via RTSP today. However, Reolink provides RTSP and RTMP support. From our testing, RTMP seems to perform better. Many users were complaining about the No Signal message when using RTSP from BI. When switching to RTMP, the cameras worked perfectly for the mainstream and the sub stream.

reolink_rtmp_optimized.png
reolink_rtmp_optimized.png (149.77 KiB) Viewed 953 times

In order to leverage the RTMP stream from Reolink, the Network IP Configuration dialog needs to look like below (note the RTMP choice for Model and usage of Port 1935 for media):

reolink_ip-config_optimized.png
reolink_ip-config_optimized.png (50.14 KiB) Viewed 952 times

I believe the RLC 4 & 5 series both provide ONVIF support. If so, you can simply leverage ONVIF to populate the main and sub stream URIs. Please review IP Camera Connection document for details on connecting cameras correctly.

If not, selecting the "*RLC-410... Baseline RTMP" Model will also populate the mainstream. Simply copy/paste mainstream to sub stream. Change "main" to "sub" in sub stream URI as seen above.

RLC-423 PTZ customer intel

According to another user, changing settings (e.g. encoding from H.264 High to H.264 Baseline) on the RLC-423 requires a restart. There may be a firmware bug that resets the PW, IP address from static to DHCP among other settings when performing a restart. Reolink support states no more support for this camera and recommends upgrading the camera.

According to a user, the RLC 423 Make/Model does not work. However, the camera connects via ONVIF. Unfortunately, PTZ controls do not come across through ONVIF.

rlc 423.png
rlc 423.png (8.63 KiB) Viewed 1714 times


510A/520A: 5 MP with person/vehicle detection

Users are reporting a bad experience when connecting cameras to Blue Iris. One user reported receiving new firmware (v3.0.0.206_21031688). The firmware resulted in main/sub fps speeds of 20 FPS. Prior, the speeds were 4/15 FPS respectively. On BI, the mainstream lagged by 10s, drops to 2-4 fps and eventually causes BI to crash. Similar issues, i.e. crashes, BI freezing up stated by other users.

Another user said RTSP streams work well using settings below (810/620).


RLC-810A

2021-May-26 Update

Below IP Config Settings seem to work according to another user.

reolink rlc-810A.png
reolink rlc-810A.png (116.45 KiB) Viewed 2588 times

Anecdotal: One more quick feedback…checking the Decoder compatibility mode on the Video=>Configure page, seems to allow the dual stream to work on the 810-A. Not sure what happens by checking this box, and it does come with some occasional brief video glitches, but the CPU usage drops and it seems that the sub stream is being monitored. Hope this condition can eventually be fixed.



2021-May-5 Update

The below settings tend to work. Yes, h265 is in the main uri, while h264 is in the sub uri. NOT a typo. Make sure to select Decoder compatibility mode.

reolink 810A.PNG
reolink 810A.PNG (173.54 KiB) Viewed 2805 times

The camera settings for sub/main (left / right) is below:

reolink 810 camera settings.PNG
reolink 810 camera settings.PNG (171.97 KiB) Viewed 2805 times


Reolink RLC 820A

2021-Aug-29 Update

RLC-820A is running firmware v3.0.0.412_21063001
Blue Iris 5.4.7.11

User comments
With the attached config I've pretty much eliminated video artifacts (minus that annoying everything turns grey in the x265 stream periodically) and this audio issue is the last one I'm hunting down.
I've attached my config for the RLC-820A since it seems to keep its sync the longest.
One thing I can tell you is decoder compatibility mode is no longer required with the later firmware, and just introduces more artifacts

Also, I've asked around, and the audio drift is very much an issue on the Reolinks, but I think I may have figured out the root cause and it's odd. I need more time to test to say it's "stable" but it seems to be related to the Reolink keeping time. They seem to keep "fast" time and get ahead. By default, once a day, they reach out to the NTP server and sync their time. Something happens where it adjusts the video, but not the audio stream when it syncs the time (even if ignoring OR subscribing to the RTSP time codes), causing the audio to end up further and further ahead with each time sync. Adjusting my time sync interval to test it, has caused the audio/video to stay in sync, for how long, I don't know.

The RLC820A doesn't need the time codes, and honestly in the below config does everything mostly well.
RLC820A_Reolink_Config.PNG
RLC820A_Reolink_Config.PNG (102.42 KiB) Viewed 942 times

Original post
RLC-820A is problematic. Engineering stated they got the camera working, albeit at just 7.5 fps (over the internet). Maybe better on the LAN.

They stated they had to lower the resolution on the main stream to get a constant fps of 7.5. The defaults would fluctuate between 3 - 8 fps.
Main and sub streams were set to 15 fps. Only 7.5 fps coming across as stated above which is ok. Make sure all streams have same fps so BI time reconciliation is easier.



RLC-822A

2021-Aug-29 Update

Firmware: V3.0.0.412.

User comments
Unlike the RLC-820A, the RLC822A DOES need the RTSP timecodes, or the audio will go out of sync. The audio is also constantly blipping a bit when using the time codes, but it at least stays in sync. Also, I made a massive network buffer, and a 15 second pre trigger. It used to be 12.5, but I would occasionally end up with the weird grey everywhere and only the moving object visible. The bigger pre trigger (or network buffer? I did both at the same time) seems to ensure there's a keyframe. Also I've adjusted the keyframe interval on the camera itself and it's 1 during the day, but still takes a dump at night with the newer firmware. The key thing to all of this is not letting the reolinks update their time and it seems to work better.

And LOL at notifying Reolink, if I knew what I know now, I'd never buy any of their terrible products. One of my cameras arrived broken and I've had the misfortune of dealing with their support already, I'm fairly certain they'd do nothing with the above mentioned information.
RLC822A_WorkingButBlips.PNG
RLC822A_WorkingButBlips.PNG (103.54 KiB) Viewed 939 times

Original Post
A user finally got the 822A working with the following firmware: V3.0.0.412.
User states ONVIF settings pulled using port 8000 were problematic.
Settings on camera:
  • The firmware allowed key frames to be 1.
  • Since sub stream is limited to 15 user set main to 15 as well to make stream synchronization easy for BI.
The below IP Config Settings seem to do the job.

rlc 822A.png
rlc 822A.png (178.91 KiB) Viewed 1417 times

Please note, the Get ONVIF trigger events is optional. Since the camera has built in AI, nothing wrong in testing the functionality.


E1 Zoom

E1 Zooms should now work in BI. Some gotchas include switching the H.264 profile from High (default) to Base. According to one user, the setting is buried in the camera's web interface. The setting can be found in the Playback -> Basic settings page as seen below.

E1 zoom settings.png
E1 zoom settings.png (18.52 KiB) Viewed 2271 times

When connecting the cameras, select the BI drivers instead of ONVIF to connect via RTMP instead of RTSP.
E1 zoom driver.PNG
E1 zoom driver.PNG (2.74 KiB) Viewed 2271 times

E1 Pro

Unfortunately, E1 Pro only has the RTSP interface. Users have stated the RTSP connection is still bad, constantly disconnecting over time. According to the user you can prevent this insane disconnect thrashing by manually setting the Video -> Image Format -> Max Rate to 1 FPS below the actual configured FPS of the Camera. I have the camera at 7FPS fluent, 8FPS clear, so I set Blue Iris to expect 6 fps. With that, the disconnect issue magically goes away. (Sounds to me like the Reolink hardware cannot push more than 8 fps continuously like BI prefers. Hopefully, new firmware updates will improve the user experience)

Sounds like Decoder compatibility mode is providing better results. Users are saying so for 810 series and now also for the E1 Pro. Test with the setting on/off to determine best results.

e1-pro-onvif_optimized.jpg
e1-pro-onvif_optimized.jpg (77.48 KiB) Viewed 3364 times

Reolink B800

The B800 series have been replaced by the 810/820 lineup so probably not widely used anymore. However, it turns out while the camera claims ONVIF compatibility, in fact the camera is closed and proprietary.

Here is a great article on one engineer's journey to reverse engineer the B800 to access the streams.


Final Thoughts

2021-Jun-10: With all these very high resolution (8MP) cameras becoming more and more pervasive, there is an increased load on your networking equipment. Closed a ticket yesterday after a user discovered the core issue was his modem/router could not handle the traffic from his 810A causing No Signal errors on BI(see below).

"No, only one camera was initially causing trouble. I have 4 reolink and the amcrest. Interestingly, the wireless reolink worked great. The poe 810A was the most problematic,..and I think also the highest resolution. Hence, perhaps some timeouts or something with my old / bad modem. No problems since I replace the modem."
brendanjacques
Posts: 8
Joined: Fri Feb 26, 2021 4:33 pm

Re: Reolink Gotchas

Post by brendanjacques » Fri Feb 26, 2021 4:46 pm

I'd like to add to this thread that this issue exists with the Reolink RLC-822A as well. Subscribing to only the main stream results in smooth 4K video, but, as expected, also very high CPU usage. Adding the substream drops the main stream down to .5-2FPS.

Adding only the substream isn't perfect either... It freezes randomly and briefly when viewing full screen, and when viewing the live video matrix, the individual cameras only update when they're selected.

The cameras are all running Reolink's latest (and so far, only) firmware of: 20112607

Are there any updates on these issues from the Blue Iris side?
jpauljohnson
Posts: 10
Joined: Thu May 28, 2020 9:44 pm

Re: Reolink Gotchas

Post by jpauljohnson » Sun Mar 28, 2021 1:13 am

Thank you so much. I've been agonizing over this NO SIGNAL issue for months while working on a commercial install. Over 40 cameras, RLC-410-5MP, and over half had the NO SIGNAL issue. So relieved. Just reprogrammed all cameras and have NO MORE PROBLEMS. Wow. I was using the Reolink Windows Client because of this. Back to BI5!!

Thanks a million!
Post Reply