Blue Iris 5 Web Server Stops Working

Posts: 1
Joined: Wed Nov 11, 2020 6:57 pm

Re: Blue Iris 5 Web Server Stops Working

Post by royl » Wed Nov 11, 2020 7:13 pm

Hi BI forum,

After running BI for years, I've also been hit with this dreaded problem a few days ago. Has anyone found a way to resolve or at least debug the cause? Tearing my hair out!!

Here are the symptoms I'm experiencing:
  • After running for random timeframes (sometimes minutes, sometimes hours), the Blue Iris web server crashes. Port is still listening as it still responds to telnet, but http access is completely gone.
  • The only remedy is to restart the service, but it crashes again shortly afterward
  • All other Blue Iris functions such as local console, alerts, recording, etc. seem to be working.

Here are the things I've verified or tried so far:
  • Downgraded to several different versions of BI5, even known working versions
  • Switched ports. Same result (works for several minutes or even up to an hour, then BI webserver crashes)
  • Made sure traffic served by BI is reasonable by disabling streaming clients
  • Memory and CPU are at reasonable utilization (avg load is 35% and 25% respectively)
  • This machine (Haswell I5 with 32GB memory) has been reliably hosting BI for several years now and hasn't gone through any recent windows updates
  • Neither access logs nor bandwidth logs show any unusual traffic

I've also emailed support, but no response yet

If anyone can offer any advice, would definitely appreciate it!!! Thanks!
Last edited by royl on Wed Nov 11, 2020 7:16 pm, edited 1 time in total.
Posts: 1
Joined: Sat Mar 20, 2021 9:13 pm

Re: Blue Iris 5 Web Server Stops Working

Post by kogashuko » Sat Mar 20, 2021 9:21 pm

So I had this issue today and let me describe what I originally tried to fix it and what actually fixed it.

First, my server restarted due to power flickering. Yes I know I need a UPS but I have one and it is just awaiting for me to relocate the server to the other area of the house. After restart the mobile app and web UI refused to connect. However, I could still remote desktop into my server.

The server setup is a Dell R410 running Windows Server 2012r2. I have two physical NICs in the server. One NIC is for the VLAN where all the cameras are. The second NIC connects to my home network VLAN. This is done because I do not want any of the cameras to have access to the internet on their own.

The first thing I tried was a reboot. No success.
Then I tried repairing my install. No success.
I tried a full uninstall of both BI5 and the remaining configuration of BI4. Then I completely deleted the directory for both in program files and rebooted. Reinstall reboot. No luck.


I got to thinking that I might not have had Windows firewall disabled. That ended up being the case which isnt a big deal. However, I found all of the Blue Iris rules still pointed to the Blue Iris 4 directory and there was no rule for 5.

Why did this not fail right away? Well the only thing I can figure is that the ports were already open when I installed 5 and didnt reboot. There was also parts of 4 still on the system and I think Windows firewall might sometimes get the two confused. The result is a web server that sometimes works and sometimes doesnt. I am going to give it about a week stability test and then restart the thing to see if the settings hold. The fix though was simple just go into the rule manually and change the directory name from 4 to 5. It fixed it instantly.
Post Reply