WMVCore.DLL / WMASF.DLL issues after May 2019 Update Win 10

Post Reply
Fjolsvith
Posts: 3
Joined: Tue Aug 27, 2019 2:01 am

WMVCore.DLL / WMASF.DLL issues after May 2019 Update Win 10

Post by Fjolsvith » Tue Aug 27, 2019 2:32 am

Hey all,

Been running BI 4 on my Windows 10 computer.

Microsoft just installed the May 2019 update on my system and suddenly BI 4 stopped running giving the error that WMASF.DLL was missing.

Image

I downloaded BI 5 and installed it and it says WMVCore.DLL is missing.

Image

Neither version runs. I scanned the forums and tried installing the VC Runtime for 2015-2019 and that didn't fix the problem. Can anyone help with this?
User avatar
reddawg
Posts: 145
Joined: Sun Jun 30, 2019 11:29 am

Re: WMVCore.DLL / WMASF.DLL issues after May 2019 Update Win 10

Post by reddawg » Wed Aug 28, 2019 10:04 am

In the past "WMVCore.DLL missing" or "WMVCore.DLL not found" meant you were running Windows 10 N edition and did not have Media Player and related technologies installed. The solution was to download and install the Media Feature Pack from Microsoft. Since this happened after the Windows feature update installed Windows 10 version 1903 (May 2019), I suspect the previous Media Feature Pack was removed.

If you have a Windows 10 N edition OS installed then go to https://www.microsoft.com/en-us/softwar ... eaturepack and download and install "Media Feature Pack - Version 1903 ( May 2019).

If you do not have a Windows 10 N edition OS, then open Control Panel -> Program Features -> Turn Windows features on or off and install Windows Media Player under Media Features.

If you manually installed Microsoft Visual C++ Redistributable for Visual Studio 2015, 2017 and 2019, make sure you installed the correct version for your PC's architecture. On Windows 10 64-bit OS, you should install vc_redist.x64.exe, whereas on a 32-bit OS, you should install vc_redist.x86.exe. Here is the link for anyone interested: https://support.microsoft.com/en-us/hel ... -downloads
Blue Iris v5.3.9.10 | Win10 x64 version 20H2 | Dahua IPC-HFW2100, Amcrest IP2M-841W, Hikvision MINI PT DS-2CD2F52F-IS, Edimax IC-3030iWn | Intel i5-2500 CPU, 8GB Ram, Samsung 860 EVO 512GB SSD, WD Black 1TB HD.
Fjolsvith
Posts: 3
Joined: Tue Aug 27, 2019 2:01 am

Re: WMVCore.DLL / WMASF.DLL issues after May 2019 Update Win 10

Post by Fjolsvith » Wed Aug 28, 2019 9:08 pm

This fixed my problem. You were correct that I was running Windows 10 Pro N. Thanks!
Kinkypuppy
Posts: 4
Joined: Sat Sep 14, 2019 4:32 am

Re: WMVCore.DLL / WMASF.DLL issues after May 2019 Update Win 10

Post by Kinkypuppy » Sun Sep 15, 2019 1:47 am

awesome... huge thanks.....
melias
Posts: 5
Joined: Wed Nov 27, 2019 3:19 pm

Re: WMVCore.DLL / WMASF.DLL issues after May 2019 Update Win 10

Post by melias » Mon Mar 15, 2021 6:53 pm

After updating my W10 Pro N today with the following updates, BI threw the "WMVCore.DLL missing" error at startup.
Feature update to Windows 10, version 2004
KB4601050: Cumulative Update for .NET Framework 3.5 and 4.8 for Windows 10, version 2004...

I tried to install "Media Feature Pack - Version 1903 ( May 2019)" but Windows says "The update is not applicable to your computer".

I realized that I should look for a Media Feature Pack for a 2004 or newer version of W10 and I found instructions to "navigate to Settings > Apps > Apps and Features > Optional Features > Add a Feature and find the Media Feature Pack in the list of available Optional Features." That fixed my issue.

I thought I'd leave this here for anyone else who searches the forum.
Post Reply