BI 5 crashing with ucrtbase.dll fault

Post Reply
auscop
Posts: 2
Joined: Thu Sep 16, 2021 2:19 am

BI 5 crashing with ucrtbase.dll fault

Post by auscop » Thu Sep 16, 2021 2:37 am

Today Blue Iris 5 started to crash every time it was launched. The Windows Event Viewer gave the following error:

Log Name: Application
Source: Application Error
Date: 16/09/2021 12:13:08 PM
Event ID: 1000
Task Category: (100)
Level: Error
Keywords: Classic
User: N/A
Computer: DESKTOP-5OLDKFN
Description:
Faulting application name: BlueIris.exe, version: 5.5.0.9, time stamp: 0x614211c1
Faulting module name: ucrtbase.dll, version: 10.0.19041.789, time stamp: 0x2bd748bf
Exception code: 0xc0000409
Fault offset: 0x000000000007286e
Faulting process id: 0x7c8
Faulting application start time: 0x01d7aa9f8c1d48d9
Faulting application path: C:\Program Files\Blue Iris 5\BlueIris.exe
Faulting module path: C:\Windows\System32\ucrtbase.dll


After much Googling I did the following to fix the problem. Not sure if this solution has been posted before.

1) Disconnect the PC from the Internet
2) Start Blue Iris 5 (If it still fails to start then it is a different problem)
3) DISABLE all Cameras
4) Connect the PC back to the Internet
5) One by one start to ENABLE your cameras
6) If Blue Iris crashes disconnect from the Internet again, and DISABLE the camera that crashed Blue Iris
7) Reconnect to the Internet and continue ENABLING all other cameras that don't crash Blue Iris
8) Delete cameras that cause the crash and add them back.

Hope this helps.
mtsoule
Posts: 10
Joined: Thu Jan 14, 2021 7:11 pm

Re: BI 5 crashing with ucrtbase.dll fault

Post by mtsoule » Thu Sep 16, 2021 12:29 pm

Mine is doing the same thing... However, sometimes it will run for 5 minutes, and sometimes several hours before it crashes..
auscop
Posts: 2
Joined: Thu Sep 16, 2021 2:19 am

Re: BI 5 crashing with ucrtbase.dll fault

Post by auscop » Thu Sep 16, 2021 10:20 pm

For me Blue Iris 5 has been pretty stable. It is running on a new Dell i7 with 16 Gig, operating 8 x 4K cameras of different varieties all from Aliexpress. Yesterdays issue all started when I double clicked on a camera to go full screen. After that I could not exit full screen no matter what I did, I ended up pressing Esc and Blue Iris crashed. After that it would never start again, it would never get passed the "Good Morning" message, which was frustrating because it was clearly NOT a "Good Morning" :D However after reading other people having issues with ucrtbase.dll and Flight Simulator crashing and if taken offline it worked, I thought I would try the same with BI. The interesting thing is the camera I had to delete and add back was not the camera I went full screen with. Before deleting the faulty camera I left it disabled and had BI up and running on the 7 other cameras for about 10 mins. I then tried to enable it again and it crashed instantly. After deleting it and adding it back BI has been up now for about 24 hours.

It would be interesting to know the correlation between 1) ucrtbase.dll 2) online/offline mode and 3) a corrupt camera config.
ucrtbase is part of MS Visual C++ so I am guessing BI is written in C++ How all 3 variables are interconnected is a mystery to me.
Post Reply