Constant crashing after about 48hrs

Post Reply
User avatar
jerrycooke
Posts: 2
Joined: Tue Jun 15, 2021 2:24 pm

Constant crashing after about 48hrs

Post by jerrycooke » Tue Jun 15, 2021 3:01 pm

I'm at bit at my wits end with this. I've already emailed support but wondered if anyone else had experienced this.

About 48hrs after I first installed Blue Iris v5, which was working perfectly fine, I woke up to find it wasn't working. Checking I found that my service was going Starting > Running > Stopped over and over, but no luck. I disabled the service and tried to debug it, uninstalling, reinstalling, rebooting, etc. Eventually I tried deleting the registry entry and this allowed it to launch. I tried restoring the settings and it went right back to crashing again. I then reinstalled Windows fresh and set everything up again from scratch. It was working fine for around 48hrs again and has just crashed with the same issue.

It's an entirely fresh and up to date Windows 10 build, has DeepStack on it and nothing else. Only three cameras, nothing at all fancy, and my monitoring says that it's not been in any way over taxed. I'm entirely at a loss as to what could be calling this and am a bit heartbroken since it's proven to be such a better system than what I'm used to so far. The crash reports don't tell me much, unfortunately..

Problem signature
Problem Event Name: APPCRASH
Application Name: BlueIris.exe
Application Version: 5.4.7.11
Application Timestamp: 60c3cf97
Fault Module Name: BlueIris.exe
Fault Module Version: 5.4.7.11
Fault Module Timestamp: 60c3cf97
Exception Code: c0000005
Exception Offset: 00000000010b2fbe
OS Version: 10.0.19042.2.0.0.256.4
Locale ID: 2057
Additional Information 1: 28d2
Additional Information 2: 28d234a5e6c8ba930b84c9a8794e1613
Additional Information 3: b4c0
Additional Information 4: b4c0a783b1747de41592ce65fd197505
User avatar
jerrycooke
Posts: 2
Joined: Tue Jun 15, 2021 2:24 pm

Re: Constant crashing after about 48hrs

Post by jerrycooke » Tue Jun 15, 2021 3:29 pm

Just to follow up.

I just set it up fresh for the 3rd time. Got everything working, then closed it and re-opened it and found that the same issue was occurring.

I wiped the registry again and since I'd made a back-up before doing anything else I restored the backup which caused the issue to resume.

Since the issue had presented itself after crashes the first two times when it had been running as a service already, it seems like it's something happening after the cameras are added and set up.
athlonxp
Posts: 7
Joined: Mon Mar 15, 2021 6:30 pm

Re: Constant crashing after about 48hrs

Post by athlonxp » Tue Jun 15, 2021 9:53 pm

Try latest "highly-stable" version (5.4.6.3). Latest version isn't always rock stable. A good helper for these releases is watchdog functionality from "Blue Iris Tools". It restarts BI service automatically after a crash.
User avatar
TimG
Posts: 1114
Joined: Tue Jun 18, 2019 10:45 am
Location: Nottinghamshire, UK.

Re: Constant crashing after about 48hrs

Post by TimG » Fri Jun 18, 2021 6:08 pm

So three cameras, and it only fails when you have them added, but not when you remove them via the registry. That sounds like corruption of a setting file, although you have already tried a Windows rebuild and setting up from scratch which should have overcome it (unless you reloaded the exported setting file).

I would suggest turning off Deepstack for each camera first to make sure it isn't that. If I enable DS for a camera, my screen goes black and the pc eventually crashes, hence not testing it at the moment. Just check to see if yours is stable without DS.

Then it's back to basics to figure it out:

1. If you have cpu acceleration enabled, turn it off for all cameras. If that fixes it, turn it back on one by one with a delay to see if it is stable.
2. If you have time before it crashes, try disabling your cameras one by one. Leave it for the required time to see if it fails. Then enable it and disable the next one.
3. If it immediately crashes, do it the other way. Add them one at a time.
4. I'm assuming from the first post that you have already checked system health/ memory etc. One of the weirdest pc repairs I ever did was where both memory chips were faulty. No logical testing made any sense :shock:

I still think it could be settings corruption; with only three cameras it may be faster to note the settings, remove/disable the cameras then manually enter them one by one again.

Anyway, take your time, do one change at a time, and write down what you did. Good luck :!:
BI5 v54904 x64 | Win10 21H1 | Dahua IPC-HDW5231R-ZE, Foscam R2, Ertech 4MP, Neos2, 2 SD cams | BI5:1 i5-3330, 16GB Ram, Multiple SSD and HD, Homeseer 2 HSPhone, TVMosaic | BI5:2 Ryzen 1800X, 16GB Ram, Multiple SSD and HD, Homeseer 4, Emby, DVBViewer.
pbernard
Posts: 1
Joined: Thu Jul 01, 2021 5:13 pm

Re: Constant crashing after about 48hrs

Post by pbernard » Thu Jul 01, 2021 5:18 pm

Hi, seems I could have the same problem:
I tried the demo version. I can install it and configure it. It works for a day or two, then the app stop right after the demo/next page choice.
I set up a new windows10 VM (on esxi 6.5) reload BI and same problem happens.

Thinking I could be luckier with buying the lite version, I set up a Windows server 2016 from scratch (on a VM), install BI lite, configure 1 camera. Was OK . Next day, same issue the BI logo appears and then Nothing !
Has any of you an idea on how to resolve that?

Thnks
MikeBwca
Posts: 804
Joined: Thu Jun 20, 2019 5:39 am

Re: Constant crashing after about 48hrs

Post by MikeBwca » Fri Jul 02, 2021 7:33 am

Exception Code: c0000005
Exception Offset: 00000000010b2fbe

The exception indicates a memory error.

This could be a buffer overrun - that is, some process is writing memory outside it's designated storage area into other parts of memory. When this happens the program that's overrun will crash. This is most likely caused by some other process than BI, and BI is the lucky process that gets overrun and crashes.
IAmATeaf
Posts: 151
Joined: Mon Jun 17, 2019 7:48 pm

Re: Constant crashing after about 48hrs

Post by IAmATeaf » Sat Jul 03, 2021 2:56 pm

That code is an access violation error and if the app reported is Blueiris.exe then it’s most likely to cause.

I used to get the same on my system, reported it to support at the time but continued to get them for months with the faulting application being either Blueiris.exe or VCRuntime140.dll.

Tried all sorts of things to fix the issue but nothing worked, then just randomly they stopped and touch wood I’ve not had the error since.
Post Reply