Blue Iris 5 Crashing This Morning

Post Reply
rhmerriman
Posts: 2
Joined: Sat Apr 17, 2021 5:24 pm

Blue Iris 5 Crashing This Morning

Post by rhmerriman » Sat Apr 17, 2021 5:34 pm

Beginning this morning, Blue Iris 5 began starting up but initially stopped complaining about the service. It would then quickly disappear. After several attempts, I was able to unclick the option to run BI5 as a service on startup, however, that didn't help. I then tried uninstalling BI5 and then reinstalling it. It would begin startup and reach "Completing Startup" and then just disappear. I'm lost.
User avatar
TimG
Posts: 1114
Joined: Tue Jun 18, 2019 10:45 am
Location: Nottinghamshire, UK.

Re: Blue Iris 5 Crashing This Morning

Post by TimG » Sat Apr 17, 2021 5:38 pm

Hi,

Do you have BI5 set up to save the installation files ? I would try the previous version if you do. I've been having audio issues with 5.4.3.7.
BI5 v54904 x64 | Win10 21H1 | Dahua IPC-HDW5231R-ZE, Foscam R2, Ertech 4MP, Neos2, 2 SD cams | BI5:1 i5-3330, 16GB Ram, Multiple SSD and HD, Homeseer 2 HSPhone, TVMosaic | BI5:2 Ryzen 1800X, 16GB Ram, Multiple SSD and HD, Homeseer 4, Emby, DVBViewer.
User avatar
cayossarian
Posts: 6
Joined: Sat Apr 03, 2021 6:08 pm

Re: Blue Iris 5 Crashing This Morning

Post by cayossarian » Sat Apr 17, 2021 6:18 pm

rhmerriman wrote: Sat Apr 17, 2021 5:34 pm Beginning this morning, Blue Iris 5 began starting up but initially stopped complaining about the service. It would then quickly disappear. After several attempts, I was able to unclick the option to run BI5 as a service on startup, however, that didn't help. I then tried uninstalling BI5 and then reinstalling it. It would begin startup and reach "Completing Startup" and then just disappear. I'm lost.
Yeah, I noticed my installation "crashe"d too on 4/17/21 although the service indicated it was still running. I restarted the service and it upgraded to 5.4.3.7 and is running. I'm not sure if there is a problem with 5.4.3.7 since I don't use audio and someone claimed a problem with that.

The only thing I see in the BI status log is an upgrade from 5.4.3.3 to 5.4.3.7...no other issues outside of the norm. I looked in the Windows Event viewer and didn't find any BI entries other than BI trying to veto a shutdown on 4/12...I'm not sure why it would veto a restart or if that is even relevant to the current issue. The one thing I noted is that Windows had some updates it was trying to apply at the same time BI was trying to update. So maybe BI only shutdown partially but did not complete. Without sufficient log entries it's difficult to say.
syversod
Posts: 2
Joined: Fri Apr 16, 2021 4:29 pm

Re: Blue Iris 5 Crashing This Morning

Post by syversod » Sat Apr 17, 2021 7:42 pm

cayossarian wrote: Sat Apr 17, 2021 6:18 pm
rhmerriman wrote: Sat Apr 17, 2021 5:34 pm Beginning this morning, Blue Iris 5 began starting up but initially stopped complaining about the service. It would then quickly disappear. After several attempts, I was able to unclick the option to run BI5 as a service on startup, however, that didn't help. I then tried uninstalling BI5 and then reinstalling it. It would begin startup and reach "Completing Startup" and then just disappear. I'm lost.
Yeah, I noticed my installation "crashe"d too on 4/17/21 although the service indicated it was still running. I restarted the service and it upgraded to 5.4.3.7 and is running. I'm not sure if there is a problem with 5.4.3.7 since I don't use audio and someone claimed a problem with that.

The only thing I see in the BI status log is an upgrade from 5.4.3.3 to 5.4.3.7...no other issues outside of the norm. I looked in the Windows Event viewer and didn't find any BI entries other than BI trying to veto a shutdown on 4/12...I'm not sure why it would veto a restart or if that is even relevant to the current issue. The one thing I noted is that Windows had some updates it was trying to apply at the same time BI was trying to update. So maybe BI only shutdown partially but did not complete. Without sufficient log entries it's difficult to say.
:x Same issue here with BI service not running, crashes and unable to select UI or App to roll back. I'm guessing an update overnight must have caused it but just can't get the UI or App to stop crashing. Event Application Log shows. 5.4.3.7, causing the error. Just wish I could reset BI app somehow.

Faulting application name: BlueIris.exe, version: 5.4.3.7, time stamp: 0x6079d92f
Faulting module name: BlueIris.exe, version: 5.4.3.7, time stamp: 0x6079d92f
Exception code: 0xc0000005
Fault offset: 0x00000000016c3daa
Faulting process id: 0x32f0
Faulting application start time: 0x01d733c2580aced5
Faulting application path: C:\Program Files\Blue Iris 5\BlueIris.exe
Faulting module path: C:\Program Files\Blue Iris 5\BlueIris.exe
stuntflyer
Posts: 12
Joined: Thu May 07, 2020 12:31 am

Re: Blue Iris 5 Crashing This Morning

Post by stuntflyer » Sat Apr 17, 2021 8:05 pm

I am having similar issues. Three of my sites (so far) seemed to have updated to 5.4.3.7 ok, but one of them (the one with about 25 cameras on it - not sure if the number of cameras is relevant to the problem) won't allow me to start the local console. Complains about waiting on the service and then it times out. Process displays the service as "Suspended" periodically.
BI latest versions at numerous sites on both Intel and AMD platforms.
User avatar
TimG
Posts: 1114
Joined: Tue Jun 18, 2019 10:45 am
Location: Nottinghamshire, UK.

Re: Blue Iris 5 Crashing This Morning

Post by TimG » Sun Apr 18, 2021 8:27 am

crashes and unable to select UI or App to roll back.
If you have ticked the box to "Retain a copy of the update package" on the update screen, you will have a folder in the main BI5 folder called "Updates". It really is as simple as double clicking on your chosen version to roll it back. A few caveats:

1. BI5 doesn't restrict the amount of these files in the Update folder. You have to go in and manually delete the oldest ones occasionally.
2. Turn off automatic updates in BI5. Do them manually when you have the time to fix anything that may break.
3. The latest updates are not likely to help a live system; they are more likely to be functional enhancements that need tweaking - so turn off automatic updates.

BI5 has been updated to 54038 today, and that has fixed my audio issue. Manual update time :mrgreen:
BI5 v54904 x64 | Win10 21H1 | Dahua IPC-HDW5231R-ZE, Foscam R2, Ertech 4MP, Neos2, 2 SD cams | BI5:1 i5-3330, 16GB Ram, Multiple SSD and HD, Homeseer 2 HSPhone, TVMosaic | BI5:2 Ryzen 1800X, 16GB Ram, Multiple SSD and HD, Homeseer 4, Emby, DVBViewer.
rhmerriman
Posts: 2
Joined: Sat Apr 17, 2021 5:24 pm

Re: Blue Iris 5 Crashing This Morning

Post by rhmerriman » Sun Apr 18, 2021 2:48 pm

God bless you all. It apparently had something to do with a recent update. I did not have the option to save updates to a folder (in fact,couldn't find it) but I was able to manually download and install the update (5.4.3.7) upon installation, everything is back to normal. This is a small system (on a boat) with only four cameras on it (so far). I was dreading the prospect of reformatting the hard drive and starting from scratch but this saved me. A virtual beer to you all. Thank you so much.
Attachments
BI5 - Boat 1.jpg
BI5 - Boat 1.jpg (77.16 KiB) Viewed 1479 times
HST
Posts: 6
Joined: Mon Apr 19, 2021 12:21 pm

Re: Blue Iris 5 Crashing This Morning

Post by HST » Fri Apr 23, 2021 6:12 am

Just want to chime in that I am also seeing crashes since recent versions - albeit for me they are happening when changing settings from several cameras.
Post Reply