CPU 100%

shiggins9
Posts: 9
Joined: Sun Nov 22, 2020 2:49 pm

Re: CPU 100%

Post by shiggins9 » Mon Nov 30, 2020 8:08 pm

Current test: Limit decoding unless required OFF on all cameras, turned off Hardware Acceleration. There was no increase in CPU usage, so although HA had a checkmark, maybe it wasn't even working on this older i5-3470.
No spike in 12 hours, will continue test.

FPS/key: 15.xx/.50
Totals: ~4400kB/sec 15.5MP/s
HeneryH
Posts: 393
Joined: Thu Jul 18, 2019 2:50 pm

Re: CPU 100%

Post by HeneryH » Mon Nov 30, 2020 9:58 pm

Third generation = SandyBridge so it will only do H264 decoding in acceleration.

https://en.wikipedia.org/wiki/Intel_Quick_Sync_Video
MikeBwca
Posts: 668
Joined: Thu Jun 20, 2019 5:39 am

Re: CPU 100%

Post by MikeBwca » Wed Dec 02, 2020 6:11 am

Specifically, for informational purposes, what does BI say the fps/key?

I've looked at these cameras, and it doesn't appear to be any place in the cameras gui to specify a keyframe. Strange.
shiggins9
Posts: 9
Joined: Sun Nov 22, 2020 2:49 pm

Re: CPU 100%

Post by shiggins9 » Wed Dec 02, 2020 9:43 pm

You're right about the Reolink, you can't do anything about the lack of keyframe info.

I've tested for 3 days and haven't had any CPU spike. I'm optimistically considering my long-standing issue resolved. This has been plaguing me for months so I will be so excited if this is the permanent solution.

Solution:
-Limit decoding unless required-OFF on all cameras
-Hardware Acceleration-OFF on all cameras
shiggins9
Posts: 9
Joined: Sun Nov 22, 2020 2:49 pm

Re: CPU 100%

Post by shiggins9 » Fri Dec 04, 2020 5:04 am

NOOO! System was good for 3 days and then the system spiked again. I guess it still isn't reliable.

Can anyone make sense of these numbers? Why would most of the cameras' bitrates triple and quadruple? Yet the FPS is at 0 and CPU 100%

Bitrate in the Reolink config is 4096kbps max and when they are working normally they are ~500kb/sec.
Attachments
Screenshot_20201203-233454_Microsoft Remote Desktop-1000.jpg
Screenshot_20201203-233454_Microsoft Remote Desktop-1000.jpg (62.69 KiB) Viewed 815 times
Screenshot_20201203-232117_Microsoft Remote Desktop-1000.jpg
Screenshot_20201203-232117_Microsoft Remote Desktop-1000.jpg (63.53 KiB) Viewed 815 times
MikeBwca
Posts: 668
Joined: Thu Jun 20, 2019 5:39 am

Re: CPU 100%

Post by MikeBwca » Fri Dec 04, 2020 9:22 am

In your cameras video settings (Not BI), is there an option for 'Enhanced night vision'? If so, disable it.
mrmike987
Posts: 1
Joined: Thu Dec 17, 2020 6:31 pm

Re: CPU 100%

Post by mrmike987 » Thu Dec 17, 2020 6:40 pm

I just had this same problem. All my settings were good but was still running at 100%. So I started disabling each camera one by one while watching the CPU %. I have 14 cameras and 13 are Foscam and 1 is Amcrest ProHD 1080P WiFi Camera 2MP. When I got to the Amcrest and disabled it the % went down to 20%. So now with all cams on except the Amcrest im running between 25 and 30%.

I don't know why this one camera was doing this but I'm not using it anymore.
atreyu
Posts: 21
Joined: Fri Nov 27, 2020 7:22 pm

Re: CPU 100%

Post by atreyu » Sat Dec 19, 2020 1:47 pm

Are you using dual stream configuration? The few hundred kbps makes sense for SD and the few thousand kbps makes sense for HD. Maybe BI is having trouble with that. Maybe it gets stuck trying to motion detect the HD streams? I have my streams individually configured in my setup and only analyzes the SD.

I have a system of 5 Reolink’s that is working fine on an i7 which is also running Home Assistant and DeespStack for AI image detection and it runs 20-30%. It did need to get ram boosted past the 8gb it originally had. With 24 it is typically around 9gb in use.

My suggestion would be to configure the streams individually and follow this site’s recommended settings if you haven’t tried this yet.
https://www.jesseweb.com/security/optimizing-blue-iris/
atreyu
Posts: 21
Joined: Fri Nov 27, 2020 7:22 pm

Re: CPU 100%

Post by atreyu » Sat Dec 19, 2020 4:16 pm

And ensure your Reolink camera firmware is up to date.
Post Reply