Image push notification not always working on Android.

Post Reply
Kev1979
Posts: 1
Joined: Fri Oct 09, 2020 10:22 pm

Image push notification not always working on Android.

Post by Kev1979 » Sun Oct 18, 2020 12:12 am

I have serous issues with Android and image push notifications on newer versions of 5. I have rolled back to version 5.2.6.5 and it fixed the issue. I get images 100% of the time where as before was maybe 20%. I have tried regular HTTP, HTTPS port forwarding, Stunnel and NGROK. All with the same result. Here is how the problem presents itself. On a fresh reboot of the BI server and the phone app has not been opened and connected yet, I trigger a camera that has a Rich push notification enabled. When I get the alert on my phone It may or may not work 50/50. I then open the app on the phone. It connects. I then go to BI logs on the PC and I can see my phone has logged in. I manually trigger the camera again an it will fire off an alert. This time with an image around 98%- 100% of the time. Now if I put the phone down and not touch then look at the BI logs on the computer, I will see the App user log off after 1 to 3 min. Now If I re-trigger a camera again I get the alert with no image. That will stay like that until I open the app again, then it goes back to what I said last. Now I did just install NGROX an I was watching the logs on that operation. I see a definite issue. When the push notification do not push through with an image it will state "302 Redirection". When it does not say 302 redirection the image will always push through no problem when performing the actions above.

The questions I have are. Does anyone else with Android have this issue and can reproduce it in the same way? Also is there anyone else here that can push this testing further to correct the issue? I am running pfsense for a router. I have played with all the NAT reflection and DNS resolvers and all that fun stuff. Nothing works. With NGROK I think it bypasses the router in regard to handing that stuff anyway.

I have Emailed support about this issue.
Post Reply