Performance tuning: a surprising result, have others had this?

Post Reply
crizcook
Posts: 4
Joined: Tue Feb 11, 2020 9:07 am

Performance tuning: a surprising result, have others had this?

Post by crizcook » Sun Jun 21, 2020 10:11 am

Hi Everyone
I have 10 IP camera system running on VMWare and the CPU has always run at 80-90% and I been using Blueiris for years.

Till yesterday i always left the frames per second at camera default (I use and like Reolink cameras).
I was reading another post about performance tuning and set 4 cameras to 15 frames a second.

The surprise result: The cpu utilisation went from 80-90% to about 40-50%.

Is this what others have experienced?

Thanks
User avatar
broachoski
Posts: 41
Joined: Sun Aug 04, 2019 4:27 am
Location: Texas

Re: Performance tuning: a surprising result, have others had this?

Post by broachoski » Sun Jun 21, 2020 5:50 pm

10 to 15 fps is fine in BI
Wait until you try the new sub stream feature that was implemented in recent updates. I run 20 cameras on an gen one i7 and my CPU usage ran near 90% with my fps set at from 10 to 15. After configuring the sub streams it now runs around 25% CPU. Actually you are in good shape where you are but someone may read this and benefit.
HeneryH
Posts: 457
Joined: Thu Jul 18, 2019 2:50 pm

Re: Performance tuning: a surprising result, have others had this?

Post by HeneryH » Mon Jun 22, 2020 1:58 am

Not surprising at all, you should see an improvement at the same scale you reduce frames by. Going from 30 fps to 15 fps should halve your CPU usage.
Post Reply