SMS to TMobile phone not working

Post Reply
User avatar
CasaDelGato
Posts: 23
Joined: Sat Nov 09, 2019 1:18 am

SMS to TMobile phone not working

Post by CasaDelGato » Sat Feb 20, 2021 2:09 am

I'm setting up a little system to keep tabs on an empty house I own. I've setup an Alert Action to send a SMS to my TMobile phone, and send an email to me.

The email works, I never get the Text msg.
Is this a problem with TMobile? Or Blue Iris?
aesterling
Posts: 1
Joined: Mon Sep 23, 2019 9:51 pm

Re: SMS to TMobile phone not working

Post by aesterling » Sat Feb 20, 2021 2:55 am

When I send an email to myphonenumber@tmomail.net it’s delivered to my phone as a text. Does that work for you?
User avatar
CasaDelGato
Posts: 23
Joined: Sat Nov 09, 2019 1:18 am

Re: SMS to TMobile phone not working

Post by CasaDelGato » Sun Feb 21, 2021 5:45 am

Does Blue Iris have a log of some type that I can check to see if the Email was sent successfully?
MikeBwca
Posts: 698
Joined: Thu Jun 20, 2019 5:39 am

Re: SMS to TMobile phone not working

Post by MikeBwca » Sun Feb 21, 2021 9:22 pm

In the BI console, click the 'Status' icon. Click the 'Log' tab. Then, at the bottom, click the 'Open file' button to open the log file.
User avatar
CasaDelGato
Posts: 23
Joined: Sat Nov 09, 2019 1:18 am

Re: SMS to TMobile phone not working

Post by CasaDelGato » Mon Feb 22, 2021 3:45 am

Apparently you have to enable logging somewhere?
There aren't any log files.
User avatar
CasaDelGato
Posts: 23
Joined: Sat Nov 09, 2019 1:18 am

Re: SMS to TMobile phone not working

Post by CasaDelGato » Mon Feb 22, 2021 3:50 am

Just did some experiments sending texts to myself via email.
Sending from my own (remotely hosted) domain - the text msg never arrives.
Sending from my local ISP domain - it works.
Sending from GMail - it works.

PITA.
User avatar
CasaDelGato
Posts: 23
Joined: Sat Nov 09, 2019 1:18 am

Re: SMS to TMobile phone not working

Post by CasaDelGato » Tue Feb 23, 2021 3:23 am

So, I configured BlueIris to use the Local ISP email which worked from my home system.
Still nothing.
Looking at the status sceren, it shows the triggers happening, but I'm not receiving txt msgs or email.
If it's having problems sending email - it sure would be nice if it told me.
User avatar
CasaDelGato
Posts: 23
Joined: Sat Nov 09, 2019 1:18 am

Re: SMS to TMobile phone not working

Post by CasaDelGato » Tue Feb 23, 2021 4:05 am

Now I'm back to thinking something is wrong with BlueIris.

I've setup both Email and SMS for 3 different SMTP servers, one of which is GMail.
I did the "Test" for each of the email servers, they all worked.
(Though I am unclear as to what the "Test" button does, as it doesn't ask for an address to send email to.)

I've setup the Alert to send an email via each of the email servers.
I've triggered the motion detected, the camera frames turned red, and I waited.

NO EMAILS have arrived.

This is what the log shows:
3 2/22/2021 7:52:12.155 PM Cam3 MOTION
3 2/22/2021 7:52:12.191 PM Cam2 GROUP
3 2/22/2021 7:52:12.194 PM Cam1 GROUP
0 2/22/2021 7:53:21.982 PM New Move: nothing to do [74/168 hrs, 4.00G/10.0G, 145.2G free]
0 2/22/2021 7:53:21.993 PM Alerts Move: nothing to do [0/500.0G, 7.23T free]
0 2/22/2021 7:53:22.004 PM Alerts Delete: nothing to do [0/500.0G, 7.23T free]
3 2/22/2021 7:57:56.490 PM Cam3 MOTION
3 2/22/2021 7:57:56.510 PM Cam2 GROUP
3 2/22/2021 7:57:56.515 PM Cam1 GROUP
0 2/22/2021 7:58:22.192 PM New Move: nothing to do [74/168 hrs, 4.04G/10.0G, 145.1G free]
0 2/22/2021 7:58:22.200 PM Alerts Move: nothing to do [0/500.0G, 7.23T free]
0 2/22/2021 7:58:22.209 PM Alerts Delete: nothing to do [0/500.0G, 7.23T free]
User avatar
CasaDelGato
Posts: 23
Joined: Sat Nov 09, 2019 1:18 am

Re: SMS to TMobile phone not working

Post by CasaDelGato » Tue Feb 23, 2021 4:57 am

After coming up with the (blazingly obvious) idea of having it play a sound when alerts were sent, I found that alerts weren't being sent.
Apparently, at some time I'd clicked on the "wait until triggered at least 2 times in 2 seconds" option. Didn't remember doing that.
Turned that off, and alerts started coming in.

Txt msgs seem to ONLY work properly if sent via Gmail smtp server.
Post Reply