Version problem

Moderators: HeneryH, TimG

Posts: 85
Joined: Mon Jan 16, 2023 5:06 pm

Re: Version problem

Post by PaulDaisy » Sun Jan 29, 2023 8:02 pm

Thixotropic wrote: Sun Jan 29, 2023 3:41 pm I still haven't gotten the time to install the 1080Ti card, and frankly looking at all the work needed to install it, it looks like quite a slog and I'll be surprised if I can get it all squared away. :(
It looks more intimidating than it is. I probably spent an hour and a half before it worked, and if the setup_cuDNN script from the CP web site worked, would have ben even quicker. Since it didn't, a manual copying of the directories and adding the PATH variables was needed for me. But it wasn't too bad. The page is long but not all of it applies to Windows.
Honestly, my experiment was mostly academic. Processing times using CPU / Python were such that using AI simply wasn't practical: 3500-14500 ms per image per model. Dark models were in tens of seconds. And there has to be something with Windows and Python, as the CPU would hit 100% during model runs. Installing a T600 dropped CPAI processing to 25-100 ms per model, and the CPU load is never more than 30%. So, success, in a way. But the model I really wanted,, doesn't work for me: it only detects FedEx but not UPS or USPS. Oh well. Still is fun to see vehicles and people detected.
User avatar
Posts: 892
Joined: Wed Sep 04, 2019 7:20 pm
Location: Low-Earth Orbit

Re: Version problem

Post by Thixotropic » Mon Jan 30, 2023 2:15 am

I'm looking at the install docs, and I've downloaded the zlib library.

Does it matter where this folder goes as long as the Windows environment variable PATH is pointed to the correct place to find zlibwapi.dll?
Blue Iris 5.x | Win 10 Pro Slim | i5-12400 | 16GB RAM | GTX 1080Ti FE | 8TB RAID1 NAS | 10 Cams | 2KVA UPS
Posts: 85
Joined: Mon Jan 16, 2023 5:06 pm

Re: Version problem

Post by PaulDaisy » Mon Jan 30, 2023 5:05 am

I don't think it matters as long as it is in the path, but since it isn't used by anything else I personally put it with the rest of the CUDA toolkit.
Posts: 6
Joined: Tue Jan 24, 2023 6:59 pm

Re: Version problem

Post by giraffedog » Wed Feb 15, 2023 6:27 pm

I'm having the same issue with my instance I'm on, after each server reboot this field is blanked out and my AI detection stops using the custom models. I then have to do the dance of clicking the dots, restarting services, until they'll finally fill and everything works great until the next reboot. Anyone have a definite solution here to get this entry to stay active? Unchecked it doesn't seem to use the custom models at all.
Posts: 1
Joined: Tue Nov 08, 2022 6:39 pm

Re: Version problem

Post by GrumpyWeasel » Sat Mar 18, 2023 4:58 pm

Hi, I'm running BI and CPAI 2.0.8-Beta, and getting the same problem as Thixotropic (1st post) and giraffedog i.e. blank custom model box after rebooting. I can fix it by clicking '...' and okaying the message but it's a pain in the neck and I don't always remember to do it, so lose all custom alerts until I do. This has been happening for ages and I can't see any way for users to fix it. So, the BI and CPAI people need to get on it.

As a compromise, I've unticked 'Use custom models', set 'Default object detection' to 'Tiny', renamed my custom model to '' and overwrote that file in 'C:\Program Files\CodeProject\AI\AnalysisLayer\ObjectDetectionYolo\assets' instead of the '..\custom-models' directory. This workaround doesn't work if you want use the default Yolo models in parallel with your custom model or have multiple custom models but I don't and this loads my custom model perfectly after every reboot. It also has the added advantage of no longer giving false default detections of a 'bench' and/or 'toilet' (!) and it removes the other default object type noise when running AI test analysis.

I'll need to reapply this workaround when CPAI is updated but that happens a lot less frequently than I reboot.

I train my custom model using yolov5m, freezing twelve layers and this gives pretty good results.
Post Reply