Page 1 of 2

Problem with corrupted converted/exported files

Posted: Tue Feb 11, 2020 9:50 pm
by ctfjr
This has happened before. When I try to convert/export to MP4 format the exported file is corrupt. I can tell if its going to be corrupt by watching the green 'working' timeline on the conversion screen. If it goes all the way to end the exported file is fine. If it closes that screen before it reaches the end then the file is no good. The last time this happened I thought it was because I had changed the 'quality %' on the encoder page to 75. When I put it back to 50 everything seemed ok. Now changing that setting doesn't help. Some files are ok, some not so much (same camera). The file that I exported as MP4 and was corrupt I was able to export as AVI just fine,
Any suggestions?

Re: Problem with corrupted converted/exported files

Posted: Wed Feb 12, 2020 10:44 pm
by MikeBwca
What version are you on, and when did it start happening?

Please provide a screen capture of the Export window, and, the encoder profile.

zStrange. I just exported a few cameras, and I get no video. Just a black screen. It was workinga week ago. I've updated to the latest version 5.0.9.5.


Update:
I figured out why all my exports were black. Only happened on Encoder profiles 1 & 2. The 'Use Nvida hardware ecceleration' was enabled on encoder profiles 1 & 2! How it got enabled I have no idea. I unchecked that option on profiles 1 & 2, and now export works. maybe it was always enabled, and something else changed. IHNI

Re: Problem with corrupted converted/exported files

Posted: Thu Feb 13, 2020 1:18 am
by ctfjr
Thank you very much for the reply. I got all tingly when you mentioned Nvidia acceleration - I had mine set always but unchecked it hoping. . . no help tho
Here is a screen shot of the convert/export window that just failed - the progress bar just stopped where you see it:
config_screen.PNG
config_screen.PNG (95.26 KiB) Viewed 885 times
export_capture screenshot1.PNG
export_capture screenshot1.PNG (93.46 KiB) Viewed 885 times
I am running release 5.0.9.2

Re: Problem with corrupted converted/exported files

Posted: Thu Feb 13, 2020 1:35 am
by ctfjr
Thanks Mikebwca!

I just saw your BI version was more recent than mine. I updated to 5.0.9.5 and all is well :)

Thank you very much!

Re: Problem with corrupted converted/exported files

Posted: Thu Feb 13, 2020 9:18 am
by MikeBwca
Oh! Wow! Didn't even consider it could be fixed by updated to latest version. :oops:

Re: Problem with corrupted converted/exported files

Posted: Thu Feb 13, 2020 11:09 pm
by ctfjr
nope, didn't fix it :(
I converted a couple of files last night fine but today its barfing again. I am able to save the clips in AVI format most of the time but not MP4.

Re: Problem with corrupted converted/exported files

Posted: Fri Feb 14, 2020 2:13 am
by MikeBwca
What fixed it for me was changing the Encoder profile from 'default' to 'main'.

Re: Problem with corrupted converted/exported files

Posted: Sat Feb 15, 2020 1:21 am
by ctfjr
Tried changing to every option in the encoder profile list. Very discouraging. I even changed my viewer thinking it might be that. Just can't convert to MP4

Re: Problem with corrupted converted/exported files

Posted: Sat Feb 15, 2020 9:43 am
by TimG
Can you convert a very small file as a test ? I'm just wondering if this is a memory issue.

Re: Problem with corrupted converted/exported files

Posted: Sat Feb 15, 2020 9:05 pm
by ctfjr
Hello TimG

No even small files won't convert to MP4's. I am able to convert pretty large (>300mb) files to AVI tho. If its a memory issue I'd be pretty surprised. BI shows 3.89gb memory usage. The system has 64gb minus 12gb I use as a ram disk. Overall task manger shows:
task_manager.PNG
task_manager.PNG (26.3 KiB) Viewed 780 times