Quick Sync decoding looks bad

General discussion about Blue Iris
Post Reply
kingcrimson234
Posts: 1
Joined: Sun Oct 06, 2019 3:09 am

Quick Sync decoding looks bad

Post by kingcrimson234 » Sun Oct 06, 2019 3:18 am

I just switched my BI computer from an i7-4930k with an NVIDIA card to a less powerful machine with an i7-3770.

The thought behind that was the 4930k system was serious overkill, and didn't have Quick Sync. Using that with an NVIDIA card was simply a waste of power. I want to repurpose it as a dedicated VR PC anyway.

I am indeed using a lot less power with the 3770, but Quick Sync seems to make the decoding look considerably worse! There's a lot more artifacting on the streams from the cameras. All of them. They're all different models from several different brands. I have 5 cameras.

Is this normal? Is there some other setting I need to enable to make it look comparable to when I was using an NVIDIA card?

Another strange thing is that task manager doesn't report the BI process as using any GPU engine, but GPU-Z shows a GPU load of about 14%, so I assume it's working?

Any tips would be appreciated, thanks!
User avatar
TimG
Posts: 657
Joined: Tue Jun 18, 2019 10:45 am
Location: Nottinghamshire, UK.

Re: Quick Sync decoding looks bad

Post by TimG » Thu Oct 10, 2019 1:51 pm

So much for Flundermans advice on ipcamstalks :lol:
Blue Iris v5.3.2.8 | Win10 x64 version 2004 | Dahua IPC-HDW5231R-ZE, Foscam R2, Ertech 4MP, 2 analogue cameras on Euresys Picolo Pro 2 | Intel i5-3330 CPU, 16GB Ram, Multiple SSD and HD | TVMosaic.
spammenotinoz
Posts: 51
Joined: Tue Jul 16, 2019 11:44 am

Re: Quick Sync decoding looks bad

Post by spammenotinoz » Wed Oct 30, 2019 1:18 am

Your new PC, seems a much better fit for a dedicated BI machine, even though it is not the most power-efficient (still a step up from what you had).
Without a google, I don't know if your new proc will support H.265 and Quicksync, but who knows if\when BI will ever support that with Quicksync anyway.

My 2c.
Copy and play the media back your new recodings on the previous PC to help determine if it is a record or playback issue.
If it the Artifacting still exists when you playback the media on the previous PC, then it's a recoding issue.
Typically occurs when your disk won't keep up with the writes. I have had this even with slower SDD's, eg: WD Greens, but fine with spinning HDD's. Less likely is a network issue, but if so you should have found that by now.
As it's a dedicated PC, I would also exclude BI from Windows Defender.

If playback of your new recordings are good on your previous PC is good, then that indicates a playback issue on your new PC. If it's BVR then yes this could be a BI issue. If you use other formats such as MPEG, then most likely a codec issue. No one size fits all here, on some PC's in the codec tweaks, I need to disable H\W acceleration and on other's leave, it enabled. I tend to have the most success using the K-Lite Codec pack for Windows 10.

Disclaimer: I don't use QuickSync, as I find the Intel drivers are still crap and have memory leaks. Older ones were okay, but they have security issues. On SOME builds, I also find the frame rates drops and artifacting occurs after 20+ hours. with QuickSync enabled.
This typically is associated with a memory leak with the Intel drivers.
Yes, CPU usage is higher without QuickSync so a big help if the box isn't dedicated. But from wall measurements, I can't detect any real power saving with QuickSync. The Dedicated QuickSync core gets a workout and it get's friggin hot that the entire CPU ofcourse heats up. So on some builds with many cameras, I personally find using multiple CPU cores. as opposed to the dedicated QuickSync core keeps the heat down anyway.

So in summary, yes it's likely QuickSync, but unlikely BI can do anything about it. Compare drivers between PC's. Some H\W handles it well, and some H\W doesn't. Unfortunately, the H\W promoted on that other forum, tends to be the older models with issues.
User avatar
Thixotropic
Posts: 493
Joined: Wed Sep 04, 2019 7:20 pm

Re: Quick Sync decoding looks bad

Post by Thixotropic » Wed Oct 30, 2019 2:34 pm

TimG wrote:
Thu Oct 10, 2019 1:51 pm
So much for Flundermans advice on ipcamstalks :lol:
Heh, more like IpScamTalks :)
Blue Iris 5.x x64 | Windows 10 Pro x64 | 16GB RAM | i7-7700 3.6 GHz | 1TB HDD | 2TB RAID NAS | 8 Cameras | Dual NIC | 1KVA UPS
Post Reply