Push notifications not working Android

General discussion about Blue Iris
Post Reply
Rene
Posts: 3
Joined: Tue Apr 13, 2021 9:41 am

Push notifications not working Android

Post by Rene » Tue Apr 13, 2021 5:41 pm

Hello

I have set BI up with deepstack to detect persons, and set BI app on my android phone,
I use zerotier to connet phone to BI server.

It all worked fins when I set it up sunday, and worked for about 24 hours.

Then it is not working anymore. I have tried to update BI, delete the BI app and install the app again, but I do not get any notifications on the phone.

When I use the test function in BI, it is working fine and I am getting a push notofication.

But when i go infront of the camera it is not working. BI detect a person and is starting to record and saving the clips, but no message on the phone.

Any suggetions?
Matts1984
Posts: 395
Joined: Fri Apr 10, 2020 1:12 pm
Location: Maryland, USA

Re: Push notifications not working Android

Post by Matts1984 » Tue Apr 13, 2021 5:55 pm

Is DeepStack cancelling the alert? I was having sufficient enough cancelled alerts (and wasn't getting many false positives before) that I ended up uninstalling DeepStack last night.
Blue Iris 5.4.8.x | Server 2019 VM | Xeon X5650 @ 2.67GHz - 12 Cores | 12GB RAM | 7TB RAID | Sophos UTM WAF | 3x SV3C 5MP Bullet A | 2x SV3C 3MP Bullet A | 1x SV3C 5MP Bullet HX | 1x SV3C 5MP Dome HX | 2x Amcrest 5MP Bullet
User avatar
terk
Posts: 151
Joined: Tue Jun 18, 2019 2:36 pm

Re: Push notifications not working Android

Post by terk » Tue Apr 13, 2021 6:48 pm

Each alert on each camera can be set to only be active for certain profiles. The push alert on that camera is active for the profile it's currently on?
Rene
Posts: 3
Joined: Tue Apr 13, 2021 9:41 am

Re: Push notifications not working Android

Post by Rene » Tue Apr 13, 2021 8:02 pm

Hey

Thanks for your reply.

Dont know how to see if deepstack is cancelling the alert. But dont think so since the clips are recorded.

But since it was starting not to work i have noticed that some clips recorded have black screen in the clips overview.

The profiles are active 1 on alerts and camera.

Only thing ive just noticed is profile 0 was not active on my user, but dont think it is the problem since, the profile on alerts and on mobile app is active 1.

Thinking about dropping zerotier and try openvpn or stunnel, but not sure if it will du any change to the problem.

Also thinking about deleting BI, and start all over with new install.
nerd
Posts: 1
Joined: Sun Apr 18, 2021 9:27 pm

Re: Push notifications not working Android

Post by nerd » Sun Apr 18, 2021 9:34 pm

My Android notifications stopped working as well, on both my phone and my wife's phone. They stopped working before I set up Deepstack, but I'm not sure exactly when. I've confirmed that whether Deepstack is activated or not, notifications don't work anymore. Confirmed settings are all correct. I can see the alerts in the alerts list, but when they trigger there is no push notification sent to the phones any more.
Rene
Posts: 3
Joined: Tue Apr 13, 2021 9:41 am

Re: Push notifications not working Android

Post by Rene » Sat Apr 24, 2021 2:42 pm

It seems like it is working again.

I did not do anything other than update BI and I have deleted the BI app and installed it againg.
HST
Posts: 6
Joined: Mon Apr 19, 2021 12:21 pm

Re: Push notifications not working Android

Post by HST » Thu May 06, 2021 1:36 pm

Exactly. Ken seems to have fixed a bug. Glad that it is working again. Living on the edge, I guess ;)
Post Reply