Quality Questions - Re-encoding

General discussion about Blue Iris
User avatar
Thixotropic
Posts: 665
Joined: Wed Sep 04, 2019 7:20 pm
Location: Low-Earth Orbit

Re: Quality Questions - Re-encoding

Post by Thixotropic » Tue Jun 16, 2020 3:12 pm

You can use ffmpeg to convert BVR files, and you can tune the compression, image size, etc.
Blue Iris 5.x x64 | Windows 10 Pro x64 | 16GB RAM | i7-7700 3.6 GHz | 1TB HDD | 2TB RAID NAS | 9 Cameras | Almost Dual NIC | 2KVA UPS
User avatar
Techie007
Posts: 1
Joined: Mon Jun 29, 2020 5:58 pm

Re: Quality Questions - Re-encoding

Post by Techie007 » Sat Jun 12, 2021 7:07 pm

speedyrazor wrote: Wed May 13, 2020 8:48 pm The main issue I have with BI is that on the main mosaic screen, FPS is only about 5 FPS (CPU is only about 30%), is there anyway to get this FPS up to 15 FPS, for example (as all my cameras are at 15 FPS). The quality of the mosaic screen is ok'sh (would like FPS higher), but when clicking on a camera to view just that single stream, there should be the option to view at full camera quality without re-encoding.
speedyrazor wrote: Thu May 14, 2020 5:19 pm Yes, I already set those, but the where is there a fps setting for the main webserver mosaic view? Ill attach my current setting, which I believe is maximum quality (still not great).
Screenshot 2020-05-14 at 18.16.27.png
Hey, I know it's been a year, but your biggest complaint (low FPS and resolution on the Camera Overview/Mosaic screen) is easily fixed, and I don't see the solution posted in this thread as of yet, so I thought I'd share...

First off, I would like to suggest dialing back your encoding settings a bit. The current settings will cause it to jitter or have dropouts, in addition to making access on a phone via the app almost impossible. On your Encoder options page, set Quality back to 50%. 100% is outrageous and won't affect the issue you're seeing. Turn Limit bitrate back on and set it to 8192. Increase B-frames to 8. Set Profile to High; High 10 will cause compatibility issues.

Now to actually resolve your primary complaint, open Blue Iris. Right above the main preview pane, you should see a dropdown box that says All cameras. Right next to it is a little gear (settings) icon. Click that to open the settings page for the tiled cameras viewport. Change Default max FPS from 5 to 30, tick Specify frame size and type in something like 3840 x 2160. Untick Fast scaling to save CPU, and click [OK]. That should do it for you! If you want, you can play with the exact dimensions of the viewport to reduce the black gapping area between the individual cameras.
Post Reply