Mobile Devices - Gotchas

Articles based on common support questions.
Post Reply
varghesesa
Posts: 49
Joined: Thu Jul 11, 2019 9:52 pm

Mobile Devices - Gotchas

Post by varghesesa » Mon Aug 09, 2021 5:53 pm

Mobile App Gotchas

The Gotchas section is all about learnings from past tickets or issues.
Mobile Devices article

If you are facing video issues like Live view is choppy or you are getting a black screen when trying to playback an alert then you are having video streaming issues.
The Camera Stream Optimization article deals with all things streaming including streaming to mobile endpoints.

Below are the other learnings from tickets regarding getting the app working. For example, my push notifications stopped working. How do I fix it?

Gotcha 1: My push notifications stopped

Moved to Action maps article (Gotcha 3) which has learnings from tickets for all actions.


Gotcha 2: Recent alerts no longer show up.

As always, first update the server software to latest version. Install latest mobile app if one exists and restart the app. See if the problem goes away. (The fix for example below was a server update)

mobile-recent-alerts-bug_optimized.png
mobile-recent-alerts-bug_optimized.png (70.48 KiB) Viewed 1413 times

Break down issue into components:
  • First, confirm an alert occurred on the camera that is more recent than the one listed. From the console, the Alerts list on the clips list will show the most recent motion trigger. You will need to look in the logs to confirm an alert was sent. See Gotcha 1 for details.
  • In console -> right click in clip list -> Database->Repair/regenerate. Restart mobile app. Do the recent alerts update?
  • If you go to the Alerts tab, do you see the most recent alert for that camera? (Include info with ticket)
  • See if you can find the alert manually. Go to the camera view of the problem camera -> select the date when the last alert was sent (as determined in previous step) and see if the alert search brings up the alert. (Include info with ticket)
  • If still not resolved, now we need to include mobile app info to the ticket for BI engineering to review. See Next steps / Submitting a ticket section below.

Gotcha 3: I get the push notification with no image.
The way the 3D images work is with a "call back" to the PC to retrieve the image. You must be able to connect to the server and be able to login to the app at the time this happens.

Quick checks:
  • When you don't get the image, are you able to login with the app?
  • Update to the latest version of the app and the BI server to see if issue still persists. Features/functionality on the mobile app are not guaranteed to run with older versions of the server.
  • Does the thumbnail appear when on the WAN or LAN?
    WAN: The network setup is critical to getting the apps working on the WAN. Double check your network setup and try to determine why thumbnails no longer work. The Networking section above has details.
    LAN: If the issue resides with the LAN, see customer anecdotes below to help troubleshoot your network.
    Both: If you can never get thumbnails, then the network setup is not correct. Follow same steps as stated for the WAN.
Debug logs:

When the next notification arrives on your phone without an alert image, go to the app (do not select notification) -> ? tab -> Debug log.
Scroll to the bottom of the log and look for downloadTaskWithURL commands associated with your recent alerts.

Code: Select all

2021-09-08 7:55:10: handleRemoteNotification: 'ADF7' (MOTION_A) triggered on 'Mabury Square' at 7:54:39 AM, long-chime-sound.wav 264
2021-09-08 7:55:10: Server now Mabury Square --> 4 server=Mabury Square, cam=ADF7, wanip=(null)
2021-09-08 7:57:40: downloadTaskWithURL http://10.0.0.5:7000/thumbs/alert.2057329278.jpg?session=54d67b8a1a3b65880775655e0eb1098d fails The request timed out.
2021-09-08 7:57:40: Requesting image from http://xxxx.ngrok.io/thumbs/alert.4118562208.jpg?session=2e4742d111f37fc81f1b3e2a25ee13d6
2021-09-08 7:57:40: downloadTaskWithURL http://xxxx.ngrok.io/thumbs/alert.4118562208.jpg?session=2e4742d111f37fc81f1b3e2a25ee13d6 fails The resource could not be loaded because the App Transport Security policy requires the use of a secure connection.
2021-09-08 7:58:39: didDetermineState: 1
2021-09-08 7:58:39: http://xxxx.ngrok.io --> {
    cmd = geofence;
    inside = 1;
    session = 00a939f740fe6f735b582ded29ce028d;
}
2021-09-08 7:58:39: http://xxxx.ngrok.io/json <-- {"result":"success","session":"00a939f740fe6f735b582ded29ce028d"}
2021-09-08 7:59:20: downloadTaskWithURL http://10.0.0.5:7000/thumbs/alert.4118562208.jpg?session=2e4742d111f37fc81f1b3e2a25ee13d6 fails The request timed out.
If you are using a DDNS/VPN service like NGROK or ZeroTier, what is important is whether the URL is populated with IP addresses or URL links. Confirm URL links from your DDNS/VPN service are being used (Line 5). If not, check your Global settings -> Web Server tab in the PC software to make sure the NGROK/VPN address is set and not the WAN address, e.g. 99.x.x.x address. You can then uncheck the option to automatically refresh this so that it sticks on the NGROK/VPN address.
web server ngrok.png
web server ngrok.png (10.83 KiB) Viewed 1413 times

There are 2 requests per notification (Line 3 and 5) because the app automatically checks the LAN and WAN addresses.

Line 5 as you scroll right already states the WAN URL failed because of TLS issues.
The fix is to go to your mobile app server settings and set the WAN address to https instead of http. Fortunately, NGROK includes encryption (https) with their free version.
Line 9 (last line) states the LAN request timed out.
In this example, both requests failed and the notification was sent without an image.



Customer Anecdotes (all network configuration issues)
Maybe triggers ideas as to what is wrong with your network setup.

Anecdotal 1:
Issue from a user where Push notifications worked on the WAN but not the LAN.
  • User switched to dynamic DNS (e.g. NGROK) from port forwarding. Changed mobile app WAN server settings accordingly.
  • Modified his local dns server to map the dynamic dns hostname to the internal IP. This user had a DNS server, perhaps company deployment. Most homeowners do not.
  • BI Server was not using the LAN interface associated with above DNS server, so ddns URL was not being resolved to correct IP address. (oops)
The above is complicated for the average user and I doubt many have a local dns server.

Anecdotal 2:
It was a local IP issue. My WiFi LAN router assigned somehow assisted devices on the WiFi network a 192.156.**.*** oddly it assigned things plugged in via cable a 10.0.0.***. It was acting like a double NAT inside the same router/WiFi box. Oddly it had separated the WiFi and wired connections on separate LANs.

I put the WiFi side into bridge mode and let only one side assign the IP addresses. This forced both the wired and wireless devices on to the same IP setup 10.0.0.***. It took a few minutes for the network to rediscover everything. I rebooted everything.

Boom. It works.

Anecdotal 3: ZeroTier deployment
I think that I have the issue with the thumbnails resolved. I use ZeroTier to remote connect my devices together when away from home. It sets up a virtual networking adapter on the PC. I had the BI web server set to use that adapter, which worked great but seems to be preventing the thumbnails from working. I have the WAN IP set to the ZeroTier IP. In the past that was the only way I could get it to connect when both at home and travelling. When I switched BI back to the default adapter and restarted I started getting thumbnails again. Not sure if or what has changed. I tested it on cellular using the ZeroTier service and I also got thumbnails. Hopefully this will still work when I travel.

What's confusing is that I was able to log in from the app with either adapter set just fine. But somehow it makes the thumbnails stop working. I've attached the app debug with both settings in case that helps you.

The delayed push notifications also seems to be resolved for now. I won't know for sure until I've had a few days. It was seeming to be reasonably quick when I directly tested it but then start to get slow after time. Hopefully it was related to the above issue. But if it returns I will let you know.

If still cannot resolve the issue, when the next Push notification goes out, wait 30s, then go to Next steps / Submitting a ticket section below to submit a ticket.


Gotcha 4: Long delay before alerts received on mobile device.
  • Walk through Windows Tuning article to make sure BI is not in conflict with Windows.
  • Gotcha 1 explains how to examine the Status->Log to determine how fast the server is processing Motion trigger -> Alerts.
  • If the log shows Success, yet the alert is not received, Blue Iris received a successful "handoff" to Google/Apple. It's then up to Google/Apple for the "last mile."
  • Unfortunately, your Cellular and ISP service provider and/or Google/Apple controls how fast alerts are received.


Gotcha 5: PTZ Controls are greyed out.
  • There is no such thing as PTZ controls when viewing a group of cameras, i.e. group view.
  • Camera settings -> PTZ tab. Enable Pan/Tilt/Zoom etc. checkbox has to be selected.
  • Global settings -> Users tab. The user using the app has to have PTZ privileges. PTZ/Control has to be checked.


Gotcha 6: Recent alerts are blank.

First make sure you did not accidentally delete the alert yourself in the app as seen below. (two scenarios)

alert list gotcha.png
alert list gotcha.png (146.53 KiB) Viewed 1413 times
alert list gotcha 2.png
alert list gotcha 2.png (232.16 KiB) Viewed 1413 times

Artificial Intelligence
The other possibility is only confirmed alerts appear on the mobile app.
The most common reason for a cancelled alert is Artificial Intelligence (DeepStack or Sentry AI) cancelled it.



Gotcha 7: Motion overlays are not visible

Go to the playback window for an alert.
Click the 3 dots button in the top right.
Video overlays are usually the BI timestamp but could have customizations based on the user.
Motion rectangles obviously show the motion overlays.
mobile article motion overlays.PNG
mobile article motion overlays.PNG (101.59 KiB) Viewed 1205 times

Also, keep in mind, if you have Re-encode instead of D2D as your Record setting, Motion overlays are not recorded unless you have them turned on during Live view. Camera settings -> Trigger tab -> Motion sensor.

mobile article motion settings.png
mobile article motion settings.png (4.21 KiB) Viewed 1202 times

Gotcha 8: Camera streams no longer appear.

First check if the network is still setup correctly. Easiest way to do so is from your mobile device, in a browser, can you login to the web interface. If so, then the network is setup correctly. If not, you need review the network case below and/or go through the Remote Access Wizard to figure out the network issue. The Remote Access Webinar walks through the Wizard steps. https://www.youtube.com/c/BlueIrisSupport/videos

If the network is fine, your server settings are not correct. Logout and use the lookup key to reset your network settings. See The Server Manual Setup section above.


Gotcha 9: Network is setup using port forwarding. Router restarted/replaced by own volition or power outage occurred

See Gotcha 1 in Networking article.


Gotcha 10: Some cameras do not show live video

mobile no camera.png
mobile no camera.png (107.76 KiB) Viewed 1413 times

Fix1:
Highly unusual. The most common reason is if the camera has no signal or lost signal. See No Signal article to troubleshoot.
Outside of the camera not connecting from the Console, the only other way this is possible is if webcasting for that camera was disabled.

webcast disabled.png
webcast disabled.png (19.71 KiB) Viewed 1413 times

Fix2:
The video pipeline: Camera feed -> Decode -> Encode ->Mobile device live view.

Decode: Turn Decode on/off to see if video improves
Camera settings -> Video tab. Hardware decode = Default (On) / No (Off)

Camera feed: See Camera settings article on optimal encoding settings on a camera.


Gotcha 11: Missing alerts in Alerts tab on mobile device versus the Alerts tab on the Console

mobile alerts missing.png
mobile alerts missing.png (76.45 KiB) Viewed 1408 times

The Alerts tab on the mobile device should normally be identical to the Alerts tab on the console. If they are not, than either
  • Cameras are not enabled or
  • Cameras are hidden

Gotcha 12: Audio or 2-way audio

Step1: Camera connector

To get audio to work, especially 2-way, you have to choose the Make / Model appropriate for your camera in the IP Config dialog.
Generic/RTSP will likely not work.
See IP Camera Connection article (Step 4) for best practices when connecting cameras with advanced functionality.
If your camera happens to use port 34567 for the RTSP/Media port, then Make/Model = Cantonk/H.264... may work.


Step 2: Confirm BI Server settings.

Confirm audio is enabled. Camera settings -> Audio tab.
audio tab.png
audio tab.png (13.23 KiB) Viewed 1396 times

Step 3: Console test

While testing from the desktop, make sure audio is first turned on for BI and the computer.
  • Computer audio is on and loud enough to hear.
  • BI audio is on and loud enough to hear. Top right of screen.
    console sound bar.png
    console sound bar.png (22 KiB) Viewed 1396 times
  • Select the camera. Confirm audio is active for the camera. Top left of camera mosaic window.
    console mosaic sound.png
    console mosaic sound.png (110.96 KiB) Viewed 1396 times
If console test fails, check Setup RTSP back-channel for talk support (PCM-U format) in the IP Config dialog.
Unlikely it will work, but a simple test so why not try.


Step 4: Browser test

Test from a browser (could be from a browser on the phone as well)

From a mobile browser, go to the web interface (UI3) and confirm audio works for both the LAN and WAN.


Step 5: Test from the mobile app

Before testing on the mobile app, update to the latest version of the app and the BI server.
Features/functionality on the mobile app are not guaranteed to run with older versions of the server.


If you still cannot get the audio working, the Next steps section of the Mobile devices article has details.


Gotcha 13: Cameras do not show up on the phone

If cameras are visible on the console but do not show up on the mobile apps, there must be a permissions issue.

In the console, did you make the camera hidden?
FYI, we're trying to move away from hidden cameras because it often leads to confusion.
See 5.5 Release notes for details.
viewtopic.php?f=13&t=2628

Otherwise the user account used to login to the phone app does not have permission to access the camera.
Double check your user settings. Global settings -> User tab.
mobile_camera groups.png
mobile_camera groups.png (8.21 KiB) Viewed 4 times
Post Reply