Mobile Devices

Details on the five major steps to configure and deploy Blue Iris.
1. Connecting IP cameras.
2. Configuring your home or office network for Remote Access via a web browser or the phone apps.
3. Setting up Storage and Recordings.
4. Creating Triggers and Alerts.
5. Creating Schedules and Profiles
Post Reply
varghesesa
Posts: 18
Joined: Thu Jul 11, 2019 9:52 pm

Mobile Devices

Post by varghesesa » Tue Apr 06, 2021 12:13 am

Introduction
This article walks you through connecting your iOS/Android devices (phones, tablets) to your Blue Iris server. It walks through all the dependencies and potential pitfalls when trying to setup your device.

If you prefer to watch the webinar associated with this article, checkout our YouTube channel. Webinar name: Mobile Devices and Apps.




Windows and Blue Iris
There is no way for the BI server to communicate with your LAN devices unless Windows settings are not in conflict with your BI server. The Windows System Tuning article will walk you through all the checks.




Networking
There is no way for the mobile app to communicate with the Blue Iris server once you leave your LAN, i.e. home network, unless you setup your network to do so. Push notifications to iOS or Android phones will not work either since BI cannot talk with the Apple and Android servers.

The Remote Access Wizard walks you through the steps to setup your network. The Remote Access webinar guides you through the process. https://www.youtube.com/c/BlueIrisSupport.
  • Most users are using NGROK (ddns) these days since it's easier. The NGROK section in the Help file provides details.
  • Tech saavy folks still use port forwarding. In the webinar, I walk through port forwarding via an AT&T Pace gateway device. Setting up your specific router/gateway is beyond BI support.
Documentation to setup NGROK. See BI Help file.
SSL connections with https (STunnel). See BI Help file.

Checkpoint: Windows is setup correctly. The network is setup correctly.




Phone settings
First try connecting through the LAN, i.e. Wi-Fi connection. Then turn off the Wi-Fi connection and try connecting via the cellular network, i.e. WAN address.

Easiest way to setup your phone settings to connect and work well with the BI App is to use the Wizard within the Add New Server function.
FYI, the BI Mobile App can connect to multiple servers.

Add new server.PNG
Add new server.PNG (40.8 KiB) Viewed 268 times


The iOS Server Setup Wizard (helps configure iOS device settings)

ios phone settings.png
ios phone settings.png (94.42 KiB) Viewed 252 times

The Android Server Setup Wizard (helps configure iOS device settings)
android phone settings.png
android phone settings.png (80.94 KiB) Viewed 252 times


The final step is to Scan the QR Code. Where is the QR Code?
The QR Code is located in one of the last pages in the Remote Access Wizard. (see below)
QR Code.png
QR Code.png (76.45 KiB) Viewed 876 times


The Server Manual Setup

FYI, you can choose to bypass the Server Wizard and go directly to setup page. Keep in mind the setup page only connects the mobile app to the BI server. You will still need to go through the iOS app settings to provide the right user experience.

iOS manual setup.png
iOS manual setup.png (165.31 KiB) Viewed 686 times


BI Mobile App Settings (~ Global Settings)

Most of the setting descriptions are intuitive or can be understood by simply turning them on/off. Below I highlight the ones that raise tickets and cause confusion.
ios settings explained 1.png
ios settings explained 1.png (134.26 KiB) Viewed 251 times
ios settings explained 2.png
ios settings explained 2.png (53.18 KiB) Viewed 712 times

Camera settings

camera settings.png
camera settings.png (164.64 KiB) Viewed 827 times
Mapping:
  • Schedule : Camera settings -> Schedule -> Override global schedule for this camera
  • PTZ preset cycle : Auto-cycle patrol
  • PTZ event schedule : Camera settings -> Schedule -> Event schedule
  • DIO output 1 : Turn first output to on/off

What are the blue badges on my alerts?

blue-badge-explained_optimized.png
blue-badge-explained_optimized.png (130.96 KiB) Viewed 829 times

Mobile App Gotchas


Alerts Case: My alerts stopped.
  • First confirm alerts are being sent.
    status log confirmatioin.png
    status log confirmatioin.png (27.93 KiB) Viewed 245 times
  • If not, something went wrong from Cameras -> BI Trigger settings -> Sending Alerts
    1. Are the cameras working? See Camera Stream Optimization article.
    2. Are you still receiving trigger alerts? The Alerts tab in the Clip List will tell you! If not, there is a problem with the Trigger tab.
      clip list_alert.PNG
      clip list_alert.PNG (20.62 KiB) Viewed 245 times
    3. If the trigger alert is present, there is a problem with the Alerts tab.
      If you do not know how to debug alerts, watch the Triggers and Alerts webinar. The information is also available in the Alerts and Actions section of Help (Testing the Action Set).
  • If Alerts are being sent (confirmed in Status -> Log), but the phone is not receiving alerts or processing alerts.

    Double check the phone settings for the app (see Server setup instructions (top) for details):
    • Allow notifications. This enables push notifications for the BI app.
    • Allow sound notifications as well.
    Now we need to go to the app and do some troubleshooting to make sure the mobile app is processing alerts:
    1. Send a ticket from the mobile app. ?-> Send feedback to Support. This will clarify whether you are on the Android or iOS app as well as the software version you are currently running. Describe the issue once again so the issue is attached to the support info.
    2. When this occurs, Send the debug log. ? -> Debug log.
    3. Does this issue only happen when on WAN or LAN or both?
    4. Are you on the latest PC software?
    5. Can you also run through the Windows Tuning article just to make sure Windows is not in conflict with BI?
      viewtopic.php?f=12&t=2080
    Maybe it's a networking issue:
    1. Run through Remote Access Wizard to confirm all checks are still passing. See Networking section above for details.
    2. Are you using STunnel /SSL / TLS? Are you on an Android device. See Android 3.0 Gotchas.


Alerts/Networking Case: I get the push notification with no image.
The way the 3D images work is with a "call back" to the PC to retrieve the images. You must be able to connect to the server/login to the app at the time this happens. When you don't get the image, are you able to login with the app?

Does the image appear in the alert when on the WAN (cellular network) but not on the LAN?
  • Switched BI external address to my dynamic dns hostname (instead of the IP)
  • Modified my local dns server to map the dynamic dns hostname to the internal IP
  • Mapped BI to the correct internal interface (oops)
The above is complicated for the average user and I doubt many have a local dns server. You may need to reach out to support. In the mobile app, go to the ? -> Debug log page. The logs contain the interactions with the server to retrieve the image. Copy/paste info into an email and send to support. This is how to determine if there is a connection issue.



Alerts Case: Long delay before alerts received on mobile device.
  • Check the Status -> Log to confirm when the Alert was sent to understand the bottleneck. Determine whether the BI server is slow in processing Alerts or your phone is slow in receiving alerts.
    If BI is slow in processing Alerts, are you attaching an image or a GIF to the Alert. If GIF, does performance improve if you change to an image?
  • Unfortunately, your Cellular and ISP service provider controls how fast alerts are received.


Controls Case: PTZ Controls are greyed out.
  • There is no such thing as PTZ controls when viewing a group of cameras, i.e. group view.
  • Camera settings -> PTZ tab. Enable Pan/Tilt/Zoom etc. checkbox has to be selected.
  • Global settings -> Users tab. The user using the app has to have PTZ privileges. PTZ/Control has to be checked.


User Interface Case: Recent alerts are blank.

alert list gotcha.png
alert list gotcha.png (146.53 KiB) Viewed 738 times
alert list gotcha 2.png
alert list gotcha 2.png (232.16 KiB) Viewed 737 times


User Interface Case: Playback is not smooth. Live view is choppy or crashing.

The issue here is if you bring up a browser on your phone and go to the BI web interface, playback and live view work fine. When doing the same through the app, the streaming is choppy, jittery etc. This issue pops up more frequently with Android tablets.
  • Test 1: Need to make sure live stream and playback are first smooth on the BI Server. Garbage in = Garbage out.
  • Test 2: If you open a browser on the phone/tablet and go to the BI web interface (UI3), are the live view and playback a good experience. If so, then you know the problem is not with the network.
If you are still reading, then the problem probably means the player used by your device cannot handle the incoming stream well. The short answer is to go to Global settings -> Web server -> Advanced -> Encoder profiles (Choose Streaming 0 or 1) -> Configure dialog. Use the below settings to start and see if they work.
streaming settings.PNG
streaming settings.PNG (88.76 KiB) Viewed 819 times
I highlighted the values I changed from the default settings:
  • First, I turned on Constant Bit Rate (CBR). This settings caps the amount of data going to the player at 1024 kbps.
  • Next, I reduced the resolution to 856 x 480. You are streaming to a mobile device, so reducing the resolution will probably have no affect on your viewing experience. I played with "Retain aspect ratio within frame". On iOS devices, the setting seemed fine. But I noticed instability and crashes on some Android devices. It does not really change/help the user experience, so my conclusion was to just leave it off unless required for another reason.
So how did I choose the values for the bit rate and resolution? I cheated and used the expertise of the BI development team!

ui3-streaming-settings-trick_optimized.png
ui3-streaming-settings-trick_optimized.png (174.63 KiB) Viewed 817 times

Once I made the stream adjustments, I went to the mobile app settings and chose the appropriate settings for my LAN and WAN connections.
video streaming gotcha.png
video streaming gotcha.png (79.58 KiB) Viewed 816 times


Streaming Case: Cannot playback alerts or clips.

ios gotcha.png
ios gotcha.png (33.51 KiB) Viewed 869 times
Issue: If you are recording Direct to Disk (D2D) and the key frame interval is sub-par, e.g. <1, then it is possible the file is open for recording, but no key frames have actually been recorded yet so BI cannot playback.

Fix:
  • Check the key frame interval in the Status -> Camera tab.
  • If the key frame interval is <1, go to your camera settings (not in Blue Iris) and raise the key frame interval. The Camera Stream Optimization article has details.


Streaming Case: Live video.
mobile streaming.png
mobile streaming.png (138.06 KiB) Viewed 232 times
Encoding from BI is too complicated for your mobile device.
Fix: Global settings -> Web server tab -> Advanced -> Configure.
  • Set quality to 50%.
  • In the Advanced section, change Profile to main.

Network Case: Network is setup using port forwarding. Router restarted/replaced by own volition or power outage occurred

port forwarding.png
port forwarding.png (129.26 KiB) Viewed 834 times
The above diagram was used used in the Remote Access Webinar to explain port forwarding. If the above is confusing, first review the webinar which is based on the Remote Access section of the BI Help file. The Help file with the webinar is a good start to understanding Remote Access.

Based on diagram, the ISP provider originally assigned 97.56.23.168 as your WAN address. Based on diagram, the router assigned the BI Server 192.168.1.7 as the LAN address.



After the router restart:
  • ISP could have assigned a new WAN address. 97.56.23.168 -> 97.56.28.15
    Consequence: Mobile devices will no longer be able to connect to the BI server from the WAN.
    Fix: Logout of BI Mobile App -> Edit -> Lookup key. You should observe the WAN address update.

    This will only work if Global settings -> Web server tab -> Refresh external IP at startup and again every xxx is checked.
    refresh external IP.png
    refresh external IP.png (37 KiB) Viewed 250 times

    For Commercial accounts where the ISP provides permanent IP Addresses, this feature can be unchecked. For some home owners, they can test restarting their router and observe whether the same WAN address is reassigned. While not guaranteed, if the same WAN address is frequently reassigned, then perhaps this feature can be left unchecked as well.
  • Router could have assigned BI a new IP address. 192.168.1.7 -> 192.168.1.15.
    Consequence: The router's port forwarding is broken.
    Fix: Update the router's port forwarding to the new IP address. Also change the router setting to provide a Static IP Address to the BI server so it never changes again to prevent future issues.


Submitting a Ticket

Bad ticket: Unfortunately something happened and I’m unable to receive alerts, or view my cameras on my phone. I have an iPhone, yes all settings on the phone are in the on position. Please let me know what my next step is.

How would anyone know what the issue is? See the beginning of the Gotchas section, Case: My alerts stopped. Isolating the issue is key to either self-correcting the problem or reporting an issue.

If reporting an issue, also note what steps you have taken to identify the issue. For example:
  • Cameras are confirmed to be functioning. FPS = 15. I-Frame interval = 1.0
  • Confirmed triggers are still working. I see trigger alerts in the clip list.
  • Confirmed alerts are being sent. I see appropriate events in the Status->Log
  • Confirmed all network checks in the Remote Access Wizard
  • Confirmed Windows is not in conflict with BI. Ran through Windows Tuning article.
Additional follow-up questions besides describing the problem.
  • Does this issue only happen when on WAN or LAN or both?
  • If you are having a connectivity issue, can you open a browser on the phone and connect to the web interface?
  • If you are having a connectivity issue, are you using STunnel? There were many STunnel tickets recently after Android made changes to their certificate policy a while back. If Android connectivity is your concern, checkout the Android article to understand what other users did to resolve.
    viewtopic.php?f=4&t=2093
  • A short video exhibiting the issue would be ideal. Most users place the video in cloud storage like Google drive for download since it's often too large to send via email.
  • Steps to reproduce the issue.
  • Temporary login to reproduce the issue from our end. For privacy reasons, many users set the account to only have access to one or two public facing cameras such as the front door / driveway.
Post Reply